Bug 126542 - EDITING: copy spreadsheet data into existing writer table
Summary: EDITING: copy spreadsheet data into existing writer table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste-From-MSO
  Show dependency treegraph
 
Reported: 2019-07-25 13:31 UTC by ulrich.krause@amodia.de
Modified: 2022-05-30 09:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
copy and paste into existing writer table (140.74 KB, image/png)
2019-07-26 12:00 UTC, Oliver Brinzing
Details
Copy from Lo Calc OK, Copy from MS Excel KO (242.09 KB, image/png)
2019-10-07 14:48 UTC, Danny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulrich.krause@amodia.de 2019-07-25 13:31:51 UTC
Copying spreadsheet data into a writer table does not work as expected:

Procedure:
 - select several cells in LOcalc
 - Ctrl+C
 - switch to a LOwriter doc with a table
 - click into a cell of that table
 - paste

Expected result:
- Values from the selected Calc cells are filled into the respective  Writer table cells


Actual results depend on the paste mechanism:

a) Crtl+V ("normal" paste)
- a new DDE table is created in the selected table cell

b) Shift+Crtl+V ("special" paste)
- mode "calc8": behaves as in a)
- mode "HTML": Space-separated values in the selected table cell
- mode "unformatted text": Newline-separated values in the selected table cell
- mode "formatted text": New writer table is created in the selected table cell
- (other modes create images or links)

Selecting more than one cell in the writer table before pasting applies this behaviour to all selected cells in the writer table.

Feature request:
Copy mode so that the values of corresponding cells are filled into the respective cells in the writer table.

Example:

Selected cells in LOcalc: D5:E7
Ctrl+C
Clicked table cell in wirter: <Tabelle5.B2>
"paste mode" which results in
:
value of <Tabelle5.B2> := values of D5
value of <Tabelle5.B3> := values of D6
value of <Tabelle5.B4> := values of D7
value of <Tabelle5.C2> := values of E5
value of <Tabelle5.C3> := values of E6
value of <Tabelle5.C4> := values of E7

Thanks!
Comment 1 Oliver Brinzing 2019-07-26 11:59:22 UTC
confirming, with ms word/excel 2016 it works, if the writer table cells are selected before pasting data.
Comment 2 Oliver Brinzing 2019-07-26 12:00:05 UTC
Created attachment 152999 [details]
copy and paste into existing writer table
Comment 3 Oliver Brinzing 2019-07-26 12:05:52 UTC
already reproducible with AOO 4.1.5.

attached screenshot shows what happens if data is pasted special with option "unformatted Text".
Comment 4 Danny 2019-10-07 11:59:56 UTC Comment hidden (obsolete)
Comment 5 Timur 2019-10-07 13:53:38 UTC Comment hidden (obsolete)
Comment 6 Danny 2019-10-07 14:48:10 UTC
Created attachment 154801 [details]
Copy from Lo Calc OK, Copy from MS Excel KO

When you copy/paste from LO Calc to an Existing Writer table, everything works as expected. (B)

But when you copy/paste from MS Excel (2007), it pastes an entire table in the selected cell(s). (A/A1)
Comment 7 Aron Budea 2019-10-07 14:53:16 UTC
(In reply to Danny from comment #6)
> When you copy/paste from LO Calc to an Existing Writer table, everything
> works as expected. (B)
This part was fixed in bug 37223.
Comment 8 Danny 2019-10-08 12:54:57 UTC Comment hidden (obsolete)
Comment 9 Danny 2019-11-19 12:09:53 UTC Comment hidden (obsolete)
Comment 10 Danny 2020-02-10 11:17:14 UTC Comment hidden (obsolete)
Comment 11 Danny 2020-05-28 09:08:02 UTC
Hi!

I just installed the latest version: 6.4.4 (Win_x64).

There's still no way to paste an MS Excel(2007) into a LO Writer table.

I even tried the 7.0Dev version and it's the same result which means that even the next version won't have that feature. :( :( :(.

Please HELP!

THANKS!!!
Comment 12 Timur 2020-05-29 09:05:46 UTC
Low priority because there should be two workarounds:
- select cells in Writer before paste, per comment 1
- open in Calc and then paste to Writer
Comment 13 QA Administrators 2022-05-30 03:36:24 UTC
Dear ulrich.krause@amodia.de,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug