Bug 126549 - Writer scrolling glitching, worse with smaller scrolling areas
Summary: Writer scrolling glitching, worse with smaller scrolling areas
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2019-07-25 17:05 UTC by libreofficebugs
Modified: 2019-11-14 07:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description libreofficebugs 2019-07-25 17:05:20 UTC
Description:
LibreOffice Writer

Steps to Reproduce:
1. install libreoffice
2. start writer
3. try scrolling document, font list, languages list

Actual Results:
scrolling jitters up and down randomly and the scroll speed is exaggeratedly higher than anywhere else on the system. The smaller the UI area to scroll in the worse the jitters, and it will eventually get stuck scrolling down only regardless of which direction the user wants to scroll.

Expected Results:
Scrolling at the same speed as the rest of the system, and most importantly in the direction intended.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.4.2.0+
Build ID: 6.2.4-1
CPU threads: 4; OS: Linux 5.1; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF8); UI-Language: en-US
Calc: threaded

Operating System: Arch Linux 
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.58.0
Qt Version: 5.12.3
Kernel Version: 5.1.7-arch1-1-ARCH
OS Type: 64-bit
Processors: 4 × Intel® Core™ i3-8130U CPU @ 2.20GHz
Memory: 3.7 GiB of RAM
Comment 1 Durgapriyanka 2019-08-07 21:38:38 UTC
Thank you for reporting the bug. I can reproduce this bug in 

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

But, no reproduction in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 S. Christian Collins 2019-08-10 05:05:24 UTC
For me, this bug happens when scrolling via my laptop's trackpad, but does not happen when using my USB mouse's scroll wheel.

** My System **
OS: KDE Neon 5.16 64-bit (Plasma Desktop 5.16.4, KDE Frameworks 5.60.0, Qt 5.12.3)
Linux Kernel: 5.0.0.23-generic
I am using the xorg synaptics driver for my touchpad, and I am using evdev rather than libinput, if that matters at all.
Comment 3 Martin Lindermann 2019-10-23 14:43:14 UTC
Same Problem: scrolling via touchpad is erratic; while only scrolling vertically on touchpad, window scrolls horizontally then scrolls up and down. This happens with either blank or opened document. Also occurs in calc


Version: 6.2.7.1
Build-ID: 1:6.2.7-0ubuntu0.19.04.1
CPU-Threads: 4; BS: Linux 5.0; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-AT (de_AT.UTF-8); UI-Sprache: de-DE
Calc: threaded

KDE Frameworks 5.56.0
Qt 5.12.2

Linux Kernel: 5.0.0.31-generic
Comment 4 Dieter 2019-10-28 12:52:49 UTC
Previous comments confirm bug report => status NEW
Comment 5 Xisco Faulí 2019-11-11 16:59:45 UTC
Dear libreofficebugs@working.name, Martin Lindermann,
Do you reproduce this issue if you launch LibreOffice from commandline with 'SAL_USE_VCLPLUGIN=gtk3 soffice' ?
Comment 6 Michael Weghorn 2019-11-12 08:18:42 UTC
This *might* be the same as bug 126680, in which case this has been fixed for LibreOffice 6.3.1 Can you test whether the issue still happens with a current LibreOffice 6.3 version?
Comment 7 S. Christian Collins 2019-11-12 16:30:39 UTC
I'm using LibreOffice 6.3.3.2 and the bug no longer occurs for me.
Comment 8 Michael Weghorn 2019-11-14 07:42:00 UTC
(In reply to S. Christian Collins from comment #7)
> I'm using LibreOffice 6.3.3.2 and the bug no longer occurs for me.

Great, thanks for the update. Let's mark this bug as WORKSFORME then.

@libreofficebugs: Please reopen if your issue is another one and still happens with a current LibreOffice 6.3 version.