Bug 126570 - Animate GIF becomes static while playing an Impress presentation
Summary: Animate GIF becomes static while playing an Impress presentation
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.3.0.2 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images-Animated
  Show dependency treegraph
 
Reported: 2019-07-26 18:53 UTC by Volga
Modified: 2019-12-29 00:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2019-07-26 18:53:02 UTC
Description:
While I try to play an Impress presentation (.odp), I saw GIF doesn't work on screen.

Steps to Reproduce:
1. Open attachment 147130 [details]
2. Press F5 to play

Actual Results:
Before I play the presentation, I can see an animation of playing violin works proper, but while I playing the presentation, it becomes a static image, the bow doesn't move.

Expected Results:
Animate GIF ahould works while playing an Impress presentation


Reproducible: Always


User Profile Reset: No



Additional Info:
版本: 6.3.0.2 (x64)
Build ID: 728469fa359ba8c83d812146293a0b0aa53945ba
CPU 线程: 4; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded
Comment 1 Julien Nabet 2019-07-27 20:23:45 UTC
Just for the record, on pc Debian x86-64 with LO Debian package 6.3.0 RC2 or with master sources updated today, I don't reproduce this with gtk3 or gen rendering.
(Windows only bug?)
Comment 2 Volga 2019-08-01 16:16:24 UTC Comment hidden (no-value)
Comment 3 Volga 2019-08-01 16:16:53 UTC
In bug 60251 I leaves some resources to get free VMs running Windows, and you can try to reproduce.
Comment 4 Volga 2019-08-01 18:38:47 UTC
I reproduced again in a virtual machine, with Windows 7 installed.
版本: 6.3.0.2 (x86)
Build ID: 728469fa359ba8c83d812146293a0b0aa53945ba
CPU 线程: 1; 操作系统: Windows 6.1; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded
Comment 5 raal 2019-08-03 08:00:56 UTC
Works for me Version: 6.4.0.0.alpha0+ (x64)
Build ID: 6eefac3b3744f806b0a35afbd0d9669d840118f4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;
Comment 6 Durgapriyanka 2019-08-19 20:38:00 UTC
Thank you for reporting the bug. I cannot reproduce this bug in 

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

and

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 7 Buovjaga 2019-08-21 10:59:27 UTC
Works here.

Did you try in Safe mode?

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 8 Volga 2019-08-21 15:23:37 UTC
(In reply to Buovjaga from comment #7)
> Works here.
> 
> Did you try in Safe mode?
Yes, I did, the problem is still there.

版本: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU 线程: 4; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Comment 9 Volga 2019-08-21 15:36:11 UTC
Additionaly, the taskbar is always in front of the presentation.
Comment 10 Oliver Grimm 2019-12-29 00:27:03 UTC
cannot reproduce here in

Version: 6.3.4.2.0+
Build-ID: 1:6.3.4-2
CPU-Threads: 2; BS: Linux 5.3; UI-Render: Standard; VCL: kde5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE
Calc: threaded