Download it now!
Bug 126589 - AUTOTEXT: A blank character is needed between autotext-shortcut and the following word -> this is impractical
Summary: AUTOTEXT: A blank character is needed between autotext-shortcut and the follo...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Mike Kaganski
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: AutoText
  Show dependency treegraph
 
Reported: 2019-07-29 08:00 UTC by canned
Modified: 2019-10-17 07:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description canned 2019-07-29 08:00:29 UTC
After entering an autotext-shortcut, there must be a white space before pressing F3 -> this is impractical.
It would be better if the text BEFORE the cursor was interpreted as an autotext-shortcut (this is how it works in MS Word).
Comment 1 canned 2019-07-29 08:22:50 UTC
Example (AT = Autotext-Shortcut, [F3] = Keypress)

AT[F3] improvement -> works, but is impractical while editing an existing text

AT[F3]improvement -> is misinterpretet as autotext-shortcut "ATimprovement"
Comment 2 Dieter 2019-08-29 12:47:03 UTC
I confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build-ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

There must be a space between Autotext-Shortcut and the following word.
Comment 3 Mike Kaganski 2019-10-08 03:10:30 UTC
https://gerrit.libreoffice.org/80419
Comment 4 Commit Notification 2019-10-08 03:53:50 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/810cddee6d2ef0f4057337d699a1a55323faa1ba

tdf#126589: only consider text to the left of cursor as AutoText short name

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Dieter 2019-10-16 20:36:26 UTC
Mike, I confirm, that a blank space is no longer needed. But the problem is now, that LO always adds a paragraph break after AutoText. Is this the intended behaviour? For some AutoText this is very practical, for other it is not.
Comment 6 Mike Kaganski 2019-10-17 06:18:50 UTC
(In reply to Dieter Praas from comment #5)
> But the problem is now, that LO always adds a paragraph break after AutoText.
> Is this the intended behaviour? For some AutoText this is very practical, for
> other it is not.

Do you mean that this has changed after the fix mentioned in comment 4? If this existed before, then that should be a separate issue.
Comment 7 Dieter 2019-10-17 07:40:03 UTC
(In reply to Mike Kaganski from comment #6)
> Do you mean that this has changed after the fix mentioned in comment 4? If
> this existed before, then that should be a separate issue.

It's also in older versions. Sorry.

=> VERIFIED FIXED