Bug Hunting Session
Bug 126596 - EDITING: Define a paragraph format (or character format) whose text can be used as a field command
Summary: EDITING: Define a paragraph format (or character format) whose text can be us...
Status: RESOLVED DUPLICATE of bug 86790
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2019-07-29 12:51 UTC by canned
Modified: 2019-07-29 17:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Application Example (26.60 KB, application/vnd.oasis.opendocument.text)
2019-07-29 12:51 UTC, canned
Details
Word-Example (doc) (45.50 KB, application/msword)
2019-07-29 15:11 UTC, canned
Details
Word-Settings (Screenshot) (81.50 KB, image/png)
2019-07-29 15:11 UTC, canned
Details

Note You need to log in before you can comment on or make changes to this bug.
Description canned 2019-07-29 12:51:19 UTC
Created attachment 153031 [details]
Application Example

As far as I can see, there is no way to define a paragraph format (or character format) whose text can be used as a field command (in Word, there is the field command "StyleRef" -> inserts the text of a paragraph that uses this style).

Application example: Add the last marginal note of a page to the header text (see attached file)
Comment 1 Dieter Praas 2019-07-29 13:22:12 UTC
Thank you for this idea. I have some questions:

- What happens, if you open a docx-file with that field command in writer?
- Use case is clear to me. But I don't understand how to do ist practically: Does it mean you have a paragraph style like "last section" and assign this paragraph style to every last section title (in your example "Section C" and "Section E")? But what happens, if you edit the text and the last section is now Section B?

cc: Design Team
Comment 2 canned 2019-07-29 15:10:42 UTC
1) It doesn't work if I open the doc-file in Writer (see attached Word-example)
2) Yes, a paragraph style "Marginal Section" is assigned to every section-element (Title or - in my case - position frame). If the text of a section-element changes, the value in the header text changes too. If there are multiple section-elements per page, then the last one is displayed in the header text (in MS Word there's an option "Search Page from Bottom to Top", see attached Word-settings)
Comment 3 canned 2019-07-29 15:11:08 UTC
Created attachment 153041 [details]
Word-Example (doc)
Comment 4 canned 2019-07-29 15:11:33 UTC
Created attachment 153042 [details]
Word-Settings (Screenshot)
Comment 5 Dieter Praas 2019-07-29 15:27:22 UTC
(In reply to canned from comment #2)
> 1) It doesn't work if I open the doc-file in Writer (see attached
> Word-example)
> 2) Yes, a paragraph style "Marginal Section" is assigned to every
> section-element (Title or - in my case - position frame). If the text of a
> section-element changes, the value in the header text changes too. If there
> are multiple section-elements per page, then the last one is displayed in
> the header text (in MS Word there's an option "Search Page from Bottom to
> Top", see attached Word-settings)

Thanks for clarification. Sounds useful to me. Let's wait for other opinions. And I also don't know, if this is possible in odf-format.
Comment 6 V Stuart Foote 2019-07-29 17:02:08 UTC
Believe this is a standardized OOXML / ECMA-376 function.

14.5.8.61

We should be able to handle movement between ODF and OOXML.

But this was suggested some time ago for bug 86790 and reverse of dupe 96559

*** This bug has been marked as a duplicate of bug 86790 ***
Comment 7 V Stuart Foote 2019-07-29 17:32:48 UTC
(In reply to V Stuart Foote from comment #6)
> Believe this is a standardized OOXML / ECMA-376 function.
> 
> 14.5.8.61
> 
> We should be able to handle movement between ODF and OOXML.
> 
> But this was suggested some time ago for bug 86790 and reverse of dupe 96559
> 
> *** This bug has been marked as a duplicate of bug 86790 ***

ECMA 347 drafts -> current ISO 29500-1

s/14.5.8.61/17.16.5.59