Bug Hunting Session
Bug 126691 - Placement of items in Writer + Undo is 100% broken
Summary: Placement of items in Writer + Undo is 100% broken
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.1 target:6.2.7
Keywords: bibisected, bisected, needUITest, regression
Depends on:
Blocks:
 
Reported: 2019-08-04 01:26 UTC by mattreecebentley
Modified: 2019-08-08 22:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mattreecebentley 2019-08-04 01:26:47 UTC
Description:
Undo does not return item to original position

Steps to Reproduce:
1. Create a rectangle
2. Position it using it's properties under right-click
3. Try positioning it again using properties
4. Undo
5. Check properties. Location will unlikely be original position,.

Actual Results:
...

Expected Results:
...


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 Telesto 2019-08-04 16:48:24 UTC
Repro with
Version: 6.4.0.0.alpha0+ (x86)
Build ID: a675fe37abc134cc5cbf54385ca99c8d1417ce2b
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-26_09:09:34
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL

but not with
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

STR
1. Insert a rectangle
2. Right click the shape -> Position & size
3. Position and size tab -> in the position field
4. Type 4 & 4 in both decimal boxes & press OK
5. Repeat 2-4 except using 5 instead of 4
6. Undo everything
Comment 2 IM 2019-08-04 17:28:40 UTC
Thank you for reporting the bug. I can confirm that the bug is present in:

Version: 6.2.5.2 (x86)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 5c30c20101f72d973ff28c228f755e635cad14d5
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: pl-PL (pl_PL); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-08-05 09:37:14 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c4041a3b6c703254ee3977eef1a989992506772b

author	Caolán McNamara <caolanm@redhat.com>	2018-05-28 14:33:42 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-05-29 10:07:40 +0200
commit	c4041a3b6c703254ee3977eef1a989992506772b (patch)
tree	f696f93baa565d865fd8a883da6d6e9d689e9eb2
parent	66cd438e3545edecaa05aa27beb289c6a6df53fc (diff)
weld SvxSwPosSizeTabPage

Bisected with: bibisect-linux64-6.2

Adding Cc: to Caolán McNamara
Comment 4 Commit Notification 2019-08-07 20:29:08 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/bf8c682f3e956d22bb731808f16a82e44463239f%5E%21

Resolves: tdf#126691 width/height considered changed, but it didn't

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Caolán McNamara 2019-08-07 20:29:46 UTC
That seems to be the problem. Fixed in master, backports to 6-3 and 6-2 in gerrit
Comment 6 Xisco Faulí 2019-08-08 09:47:49 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 63889d3d465e9b4292dd5bb630bd3394494c8a6d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES-valencia (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 7 Commit Notification 2019-08-08 09:49:11 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/c984908be223d11b1b52d28d82f42c41eedbf8e4%5E%21

Resolves: tdf#126691 width/height considered changed, but it didn't

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-08-08 09:49:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/3c2076fd7366d4f10c6fcff1eb3cd3edc97d2167%5E%21

Resolves: tdf#126691 width/height considered changed, but it didn't

It will be available in 6.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 mattreecebentley 2019-08-08 22:13:11 UTC
Good to hear guys!