Bug Hunting Session
Bug 126693 - I cannot create custom categories for captions
Summary: I cannot create custom categories for captions
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.2.7 target:6.3.1
Keywords: bibisected, bisected
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2019-08-04 10:24 UTC by Miroslav Cupal
Modified: 2019-09-02 07:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast of adding new category (3.31 MB, video/webm)
2019-08-13 13:47 UTC, Michael Weghorn
Details
Screencast of the bug (23.32 MB, video/mp4)
2019-08-23 07:48 UTC, nerb.benedikt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miroslav Cupal 2019-08-04 10:24:24 UTC
Description:
I tried to create my own caption category in libreOffice writer, but it does not work in Fedora 30 with KDE 5. I try reproduce this bug in same version of writer in Windows 7 and everything works correctly.

Steps to Reproduce:
1. Open LibreOffice in Fedora with KDE 5.
2. Insert image.
3. Right-click on image and choose insert caption.
4. In Caption menu try to write new caption.

Actual Results:
Nothing happen

Expected Results:
It is possible to write new caption category.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.5.2
Build ID: 6.2.5.2-1.fc30
CPU threads: 4; OS: Linux 5.1; UI render: default; VCL: gtk3; 
Locale: cs-CZ (cs_CZ.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-08-07 20:21:21 UTC
do you want create new caption or new caption category? In which field did you try enter write a new caption?
Comment 2 Miroslav Cupal 2019-08-08 09:42:20 UTC
(In reply to Roman Kuznetsov from comment #1)
> do you want create new caption or new caption category? In which field did
> you try enter write a new caption?

I try to create new caption category. I try to click to filed next Category: and write name of new caption category, but it is impossible. I can use only predefined categories.
Comment 3 Miroslav Cupal 2019-08-08 13:08:28 UTC
I try to create new caption category. I try to click to filed next to Category: and write name of new caption category, but it is impossible. I can use only predefined caption categories.
Comment 4 Roman Kuznetsov 2019-08-09 16:33:05 UTC
I can confirm it for vcl:kde5 (6.4 master) and I can create new category in windows build (6.3 release)
Comment 5 Michael Weghorn 2019-08-13 13:47:08 UTC
Created attachment 153341 [details]
Screencast of adding new category

I currently cannot reproduce on current master.
Are the steps you take the same as those shown in the attached screencast or am I doing something else?

Version: 6.4.0.0.alpha0+
Build ID: f101853c7dd1e9104ccda96e61a624a0c1496f9a
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kf5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Miroslav Cupal 2019-08-14 16:23:51 UTC
Yes steps are same, but cannot write new caption category.
Comment 7 Michael Weghorn 2019-08-14 20:24:38 UTC
(In reply to Miroslav Cupal from comment #6)
> Yes steps are same, but cannot write new caption category.

Can you possibly attach a screencast on the exact behaviour you get?

Can you try whether it still happens with a current daily build from [1]? you can install that one in parallel as described at [2].

Does this also happen when you start LibreOffice with at fresh user profile, e.g. start it from command line using this command:

    libreoffice -env:UserInstallation=file:///tmp/testprofile

[1] https://dev-builds.libreoffice.org/daily/
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 8 nerb.benedikt 2019-08-23 07:48:17 UTC
Created attachment 153585 [details]
Screencast of the bug
Comment 9 nerb.benedikt 2019-08-23 07:52:48 UTC
Comment on attachment 153585 [details]
Screencast of the bug

I just ran into the same issue (on PopOS (basically Ubuntu) 19.04; LO 6.3.0.4)

I'm no expert, but to me it appears as if the textfield for entering was missing.
You can see that when I hit TAB to go to the next element (around 0:15 in the video) it 'skips' the textfield and goes straight to the dropdown arrow.
Comment 10 nerb.benedikt 2019-08-23 08:10:51 UTC
Addition: I just got the exactly same result as shown in the video with LO 6.3.2.0.0+ (the latest daily build as of now
Comment 11 Michael Weghorn 2019-08-23 18:12:10 UTC
(In reply to nerb.benedikt from comment #8)
> Created attachment 153585 [details]
> Screencast of the bug

Thanks for the video. This looks like a GNOME desktop that is probably using the gtk3 VCL plugin (you can check in "Help" -> "About LibreOffice").

Also, the initial comment's version information mentions gtk3.

I can actually reproduce now with

Version: 6.4.0.0.alpha0+
Build ID: 89dd08d15fbe57e3fbeac9a7a9906efd42788c74
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

but not with either the "gen" or "kf5" VCL plugins, so this looks gtk3-specific.
Changing meta-bug accordingly.


@Miroslav, nerb.benedikt: Can you double-check whether the problem goes away when you test with environment variable SAL_USE_VCLPLUGIN=gen (or kde integration installed and environment variable SAL_USE_VCLPLUGIN=kde5) set? 


In reply to Roman Kuznetsov from comment #4)
> I can confirm it for vcl:kde5 (6.4 master) and I can create new category in
> windows build (6.3 release)

Can you please double-check whether that was actually kde5 (now called kf5) VCL plugin? (If so, my above observations don't cover everyting.)
Comment 12 Michael Weghorn 2019-08-23 18:42:03 UTC
This was actually a side effect of welding. Bisecting points to this commit:

commit fcb2685ac23f6a1a5fb03f2ec431f8f7c43db58d
Author: Caolán McNamara <caolanm@redhat.com>
Date:   Wed Dec 12 11:50:06 2018 +0000

    weld SwCaptionDialog
    
    Change-Id: I5babfbf3489f88c5d6cdeffbd514d86368f04fa9
    Reviewed-on: https://gerrit.libreoffice.org/65014
    Tested-by: Jenkins
    Reviewed-by: Caolán McNamara <caolanm@redhat.com>
    Tested-by: Caolán McNamara <caolanm@redhat.com>
    (cherry picked from commit 72ebf150ab1f35a65de7c99e0227af77bae72be9)
    Reviewed-on: https://gerrit.libreoffice.org/65078

Probably just some flags need to be adapted in the .ui file
Comment 13 Commit Notification 2019-08-23 21:49:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/260086dffc5adddb3c6e60d423acd2aaeeb036eb%5E%21

Resolves: tdf#126693 cannot put focus into combobox entry

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-08-23 21:49:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/eb3587b1c54f7b264e6439d1cf39768c863284e4%5E%21

Related: tdf#126693 cannot put focus into combobox entry

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Caolán McNamara 2019-08-23 21:50:38 UTC
fixed in master, backports to 6-3 and 6-2 in gerrit
Comment 16 Commit Notification 2019-08-24 08:36:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/4972b71961c1ab2143d82d9af0ac498063c63ff6%5E%21

Related: tdf#126693 cannot put focus into combobox entry

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-08-24 08:37:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/87c79663f8ebd08a9a1a2222843994fc0effcf9f%5E%21

Resolves: tdf#126693 cannot put focus into combobox entry

It will be available in 6.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2019-08-26 11:37:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/fd2e3d4cd3e6375ca06fec09f2c8142259740814%5E%21

Resolves: tdf#126693 cannot put focus into combobox entry

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2019-08-28 16:40:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3-1":

https://git.libreoffice.org/core/+/fc5f21537b5e1729342bddc97e2999772482ef0e%5E%21

Resolves: tdf#126693 cannot put focus into combobox entry

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Xisco Faulí 2019-09-02 07:17:32 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!