Bug 126698 - Unable to update links to external files in Calc
Summary: Unable to update links to external files in Calc
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Calc-External-Datalink
  Show dependency treegraph
Reported: 2019-08-04 15:18 UTC by Usama
Modified: 2022-06-13 03:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:

example linked file (7.71 KB, application/zip)
2019-08-04 15:21 UTC, Usama

Note You need to log in before you can comment on or make changes to this bug.
Description Usama 2019-08-04 15:18:47 UTC
I insert A sheet from file and check the "link" check box. Then when I move the file to another computer or another user on the same system things get messy and I lose the ability to update the link to point to the new file location.

Steps to Reproduce:
1.From "Sheet" menu >> insert sheet... >> chose "from file" and browse for CSV file. Check the "link" check box save the file.
2. From "Edit" menu click "Links to external files.." then "Modify" chose another CSV file then press the update button then save and close the file
3. When you open the file again the link will still show the old CSV file

Actual Results:
OLD file is still linked

Expected Results:
The new file should be linked

Reproducible: Always

User Profile Reset: No

Additional Info:
Build ID: c54597a8905b07807952aebc24237549302fb941
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-07-10_22:22:02
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Usama 2019-08-04 15:21:22 UTC
Created attachment 153128 [details]
example linked file
Comment 2 Buovjaga 2019-08-04 17:35:24 UTC

Arch Linux 64-bit
Build ID: 4bd1b38633d6cb288eb559afc0ac6b961538ae60
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 24 July 2019
Comment 3 m.a.riosv 2019-08-04 22:58:15 UTC
I can't repro with a file from scratch
Version: (x64)
Build ID: b9b7df5f558eb79533622df5f3390f79a1e5aa79
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-07-31_17:15:25
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL

Sample file has a link relative to not the same folder but xlink:href="../../Downloads/test.txt", so if file is saved with the option for a relative path, and you move to a different place without reproduce the folder's structure then the link doesn't work.
Sample file doesn't update for me with 6.2.5.
Comment 4 Usama 2019-08-05 13:35:48 UTC
Maybe the issue is different with Ms Window? I tried the latest version from master and I still can reproduce it with new file.

Build ID: 9ee5ad5a0b84bfa652da34694ba4f75668f06087
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-07-30_13:21:44
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Buovjaga 2019-08-10 16:16:12 UTC
I repro with steps from description even from scratch on Win (build is latest from TB@39)

Version: (x86)
Build ID: c738be4de6886a0c96b7d10df7e78c8b2964c135
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 6 Buovjaga 2019-08-10 16:32:39 UTC
I tried to bibisect, but bug is not yet in latest of win32-6.3 repo, yet it is already in the oldest of Linux 6.4 repo!?
Comment 7 Xisco Faulí 2019-08-19 15:00:31 UTC
I can reproduce it back to

Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

I don't see why it's a regression...

Steps I followed:
1. Create folder Downloads and paste the .txt file there
2. Open the .ODS file
3. Update the link
4. Save
5. Reopen

-> it links to the old file.

Am I missing something ?
Comment 8 Buovjaga 2019-08-25 16:18:23 UTC
(In reply to Xisco Faulí from comment #7)
> Am I missing something ?

Try it from scratch, not with the example ODS file
Comment 9 Buovjaga 2020-06-12 12:58:02 UTC
I was wrong about the regression status: doing this from scratch, I repro with 4.4.7 and 3.3.0.
Comment 10 QA Administrators 2022-06-13 03:26:17 UTC
Dear Usama,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword

Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team