Bug Hunting Session
Bug 126705 - Cannot remove one of hyperlinks in a text block
Summary: Cannot remove one of hyperlinks in a text block
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-05 12:08 UTC by Franklin Weng
Modified: 2019-08-12 11:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with three hyperlinks in the first slide (12.06 KB, application/vnd.oasis.opendocument.presentation)
2019-08-05 12:09 UTC, Franklin Weng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin Weng 2019-08-05 12:08:18 UTC
Description:
When there are multiple hyperlinks in a text block, there is no way to remove just one of the hyperlink (and keep text).

The only way to remove hyperlink URL but keep the text is to select those texts and right-click to get context menu, and choose "Clear Direct Formatting".  However when there are multiple hyperlinks, even I just choose one of the hyperlink text and clear direct formatting, all the hyperlinks will be removed.

Steps to Reproduce:
1. Create multiple hyperlinks in a text block (like the attached sample file)
2. Select the second hyperlink
3. Right-click it and choose "Clear Direct Formatting"

Actual Results:
All the hyperlinks are removed.

Expected Results:
Only the second hyperlink should be removed and the first and third hyperlinks should be reserved.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Franklin Weng 2019-08-05 12:09:20 UTC
Created attachment 153138 [details]
Sample file with three hyperlinks in the first slide

Select the text of the second item and right-click it to choose "Clear Direct Formatting", all the hyperlinks will be removed.
Comment 2 BogdanB 2019-08-05 14:04:47 UTC
Confirm this
Version: 6.2.5.2
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 3 Xisco Faulí 2019-08-07 16:19:10 UTC
hello Franklin,
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: 1067c32964e4e0754d2d926e1319b4060ded93f5
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

after Samuel's changes related to hyperlinks, now there's a 'remove hyperlink' option that works removing only the second hyperlink

Could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 4 Franklin Weng 2019-08-11 08:46:45 UTC
"Remove hyperlink" works under

版本:6.4.0.0.alpha0+
組建 ID:91e4d876098aaa7ac18a03e20cbc2789fba98041
CPU 執行緒:4; OS:Linux 4.19; UI 算繪:預設; VCL: gtk3; 
語言地區:zh-TW (zh_TW.UTF-8); UI-Language: zh-TW
Calc: threaded
Comment 5 Xisco Faulí 2019-08-12 11:14:02 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.