Bug Hunting Session
Bug 126736 - In line dialog, tab "Line Styles", dash length and spacing cannot be larger than 5%
Summary: In line dialog, tab "Line Styles", dash length and spacing cannot be larger t...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.1 target:6.2.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-08-06 19:50 UTC by Regina Henschel
Modified: 2019-08-12 12:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example to test line style defining (16.25 KB, application/vnd.oasis.opendocument.graphics)
2019-08-06 19:50 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2019-08-06 19:50:27 UTC
Created attachment 153180 [details]
Example to test line style defining

Open attached document. Try to modify the line style, so that its spacing and dash length is 500%. It is not possible. The value in the field cannot be larger than 5%. That makes is impossible to define usable line styles. Former versions allow values up to 500%.

It is a regression. It was OK in 6.1.4 and broken at least since 6.2.5. (I haven't yet tested more versions.)
Comment 1 Durgapriyanka 2019-08-06 21:18:15 UTC
Thank you for reporting the bug. I can reproduce the bug in 

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

The value in the field cannot be larger than 2%

In version LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Spacing and dash length cannot be larger than 200%
Comment 2 raal 2019-08-07 16:01:24 UTC
Confirm with Version: 6.4.0.0.alpha0+ (x64)
Build ID: 6eefac3b3744f806b0a35afbd0d9669d840118f4
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win;
Comment 3 raal 2019-08-07 16:19:11 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara; Could you possibly take a look at this one? Thanks

449c77c8a4b5beccc696421bbb9ed776cbfb89b4 is the first bad commit
commit 449c77c8a4b5beccc696421bbb9ed776cbfb89b4
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 15 15:55:29 2018 -0800

    source sha:4ce5d39689fda418e8f2d7d9c1124190b2cbad7a

author	Caolán McNamara <caolanm@redhat.com>	2018-11-14 13:52:06 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2018-11-15 18:17:35 +0100
commit	4ce5d39689fda418e8f2d7d9c1124190b2cbad7a (patch)
tree	1e261f9e2b305fbdf56e3784c6589efbd683755b
parent	9e0a099fb66c303bec0489198ba7cfe770b28684 (diff)
bind SalInstanceSpinButton to FormattedField
Comment 4 Regina Henschel 2019-08-07 17:34:21 UTC
When working on it, please consider to increase the possible value to 800%, because the preset dash styles of OOXML use such long dashes.
Comment 5 Commit Notification 2019-08-09 12:25:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/c060e063467555b69c55ba214b400bfc68c67c3e%5E%21

Resolves: tdf#126736 change range on change of unit

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2019-08-09 12:44:36 UTC
seems to do the right thing, backport to 6-3 and 6-2 in gerrit, fixed in master
Comment 7 Xisco Faulí 2019-08-12 12:07:28 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 2812610f4f39ed5892da08864893c758325d1d39
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!
Comment 8 Commit Notification 2019-08-12 12:08:43 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/f686f17de2d894a5a65746a6548e968cd21061fe%5E%21

Resolves: tdf#126736 change range on change of unit

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-08-12 12:10:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ac996989897dca899b8fd388c32c6512021b802b%5E%21

Resolves: tdf#126736 change range on change of unit

It will be available in 6.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.