Bug Hunting Session
Bug 126740 - Not possible to select images + other items
Summary: Not possible to select images + other items
Status: RESOLVED DUPLICATE of bug 34438
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2019-08-07 00:57 UTC by mattreecebentley
Modified: 2019-08-08 22:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mattreecebentley 2019-08-07 00:57:51 UTC
Process to replicate:

Create a document
Insert a shape
insert a text box
insert an image

Try selecting the image and the shape via SHIFT + left-clicking

Does not want to work


Try selecting the shape and the text box via SHIFT + left-clicking

Works
Comment 1 V Stuart Foote 2019-08-07 14:30:58 UTC
On the Writer document canvas the Frame object (holding images/bitmaps) are not Draw objects (Text box, Shape) they have different attributes and handling.

The Text box and the Shape _can_ be <Shift>+click multi-selected. The Image frames can not be as they have a different handling with document/paragraph text.

On the Draw/Impress canvas images & draw objects can be multi-selected.
Comment 2 Telesto 2019-08-07 17:52:17 UTC
@V Stuart
I still prefer to loop this through UX-Eval... Hope you don't mind..
---

This explanation given (comment 1) is from technical perspective describing the current situation, IMHO.

I personally would like to select multiple items.. As a user I don't care to much about 'different attributes and handlings'. I want to be able to select multiple items & drag/ cut/delete..

The question is about: Do we want this to be possible (User point of view)? And if so, is this do-able in one way or another (Developer point of view)?
Comment 3 mattreecebentley 2019-08-07 21:47:29 UTC
From a users perspective, that is insane behaviour. No-one sees what's happening on the back-end. But on the front-end this is absolutely an error.
Comment 4 Regina Henschel 2019-08-07 23:51:50 UTC
I think, it is nothing for UX.

Workaround: Insert the image in Draw. Then copy it in Draw and insert it in Writer. Now you can select the objects with Shift-click.

*** This bug has been marked as a duplicate of bug 34438 ***
Comment 5 Heiko Tietze 2019-08-08 07:55:41 UTC
(In reply to Regina Henschel from comment #4)
> I think, it is nothing for UX.

At least we can confirm that's not the best usability. Let's hope for bug 34438 being fixed at some point.
Comment 6 mattreecebentley 2019-08-08 22:10:16 UTC
From the user's perspective, it's a bug - therefore it's a bug.
It completely breaks user expectation, and is not replicated elsewhere in the UI.

If you want to compete with MS Office, you can't afford to have things like this which make no sense unless you undertstand the technical back-end of the program. That's insane.