Bug 126810 - FILESAVE
Summary: FILESAVE
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-10 08:05 UTC by steffan.steffner
Modified: 2019-08-28 04:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
error displayed when trying to save a file containing not allowed characters (40.37 KB, image/jpeg)
2019-08-10 08:05 UTC, steffan.steffner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steffan.steffner 2019-08-10 08:05:45 UTC
Created attachment 153281 [details]
error displayed when trying to save a file containing not allowed characters

When trying to save a document and using invalid caracters (such as "?" or ":")in the name, then Writer displays

"Fehler beim Speichern des Dokumentes ....:
Nicht existierendes Objekt.
Der Pfad zu der Datei existiert nicht."
(if you employed ":" in the name)

or 

"Fehler beim Speichern des Dokumentes 
Kein Zugriff auf Objekt.
Aufgrund fehlender Benutzerrechte kann
auf das Objekt nicht zugegriffen werden."
(if you employed "?" in the name)


Especially for unexperienced users this is not very helpful and may leave him/her completely puzzled and lost.

The error report should read (at least as additional info):  
"You have probably used characters that are not allowed /should not be used in a file name (you should not use ?,:,/, etc. in a file name."
Comment 1 Oliver Brinzing 2019-08-10 14:39:42 UTC
with 

Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: 

if i try to save a new writer document i get:

T?ES:T - Der Dateiname ist ungültig.
::TEST - Ungültige Klassenzeichenfolge
T:EST  - Laufwerk T: ist nicht vorhanden.
         Überprüfen Sie das Laufwerk, und wiederholen Sie den Vorgang.
TE?ST  - refuses to save,

can you please add some examples ?
Comment 2 steffan.steffner 2019-08-11 10:22:11 UTC
Here some more examples:

If I try to save using the same file names that you tried in your examples, I get the follwing results on my old Laptop that runs  Win XP 
Version: 5.4.7.2  
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0 
CPU-Threads: 2; BS: Windows 5.1; UI-Render: Standard; Gebietsschema: de-DE (de_DE); Calc: group)
1)  T?ES:T - „Der Dateiname ist ungültig.“
2) ::TEST - „Der Dateiname ist ungültig.“
3) T:EST  - „Pfad existiert nicht, Überprüfen Sie, ob der Pfad richtig ist“
4) TE?ST    refuses to save,

If I try to save using the same file names that you tried in your examples, I get the follwing results on my PC 
Version: 6.2.5.2 (x64)
Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE 
Calc: threaded

1) T?ES:T - „Fehler beim Speichern des Dokumentes Unbenannt 1:
Kein Zugriff auf Objekt. Aufgrund fehlender Benutzerrechte kann auf das Objekt nicht zugegriffen werden“
2) 3) und 4)  <Ergebnis identisch zu 1>
Comment 3 steffan.steffner 2019-08-11 10:30:35 UTC
Well, the last line in my above Comment 2 should probably read "<same result as under 1,2,3>" instead of "<Ergebnis identisch zu 1>"

Just to avoid confusion.


Off topic:
I can't find the "edit function" for comments on bugzilla. Maybe somebody can give me a hint.
Comment 4 Oliver Brinzing 2019-08-11 12:17:37 UTC
(In reply to steffan.steffner from comment #2)
> If I try to save using the same file names that you tried in your examples,
> I get the follwing results on my PC 
> Version: 6.2.5.2 (x64)
> Build-ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
> CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
> Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE 
> Calc: threaded
> 
> 1) T?ES:T - „Fehler beim Speichern des Dokumentes Unbenannt 1:
> Kein Zugriff auf Objekt. Aufgrund fehlender Benutzerrechte kann auf das
> Objekt nicht zugegriffen werden“

you can check file permissions, e.g.:

C:\Users\[USERNAME]>icacls documents

Do you have full access (F) permission?
Comment 5 Jean-Baptiste Faure 2019-08-11 18:25:04 UTC
Under Ubuntu / Gnome I can save a file with a ? or a : in its name. It's a bad idea but it works.

Best regards. JBF
Comment 6 steffan.steffner 2019-08-11 22:05:36 UTC
To clarify my point:
I don‘t run into any unexpected difficulty with Writer /libreOffice:
Since I know that using characters like „?“, „:“ „/“ etc. in any file name on a computer is a bad idea, I just don‘t use it.

And to answer your question
>Do you have full access (F) permission?

Yes, when I use a „normal“ file name, I have no problem to save a file in Writer. 

So again, what I am trying to say is:
the error report that is displayed by LibreOffice Writer (and the same is true for LibreOffice Calc) is completely misleading. I come across this error report a few times a year, just because it hit a wrong touch on my keyboard (but I certainly know instantly what to do). But I am sure that this has the potential to drive beginners mad. 

I am not saying that LibreOffice should allow saving file names with „?“ and „:“ in them (if this would be possible at all), but the error report should not be misleading (as it is for the time being). 

Even MS WORD 2016 does a better job in such a case, by just saying „der Dateiname ist ungültig“ (again, when using „?“, „:“ etc. in a file name.

So, LibreOffice should definetely not give the statement „Aufgrund fehlender Benutzerrechte kann auf das Objekt nicht zugegriffen werden“.


Since LibreOffice definitely wants to be as user friendly as possible, this should be corrected. 

Again, as stated before, IMHO the error report should read (at least as additional info):  
"You have probably used characters that are not allowed in a file name (you should not use ?,:,/, etc. in a file name.)" (bzw. hier:  “der Dateiname enthält unzulässige Zeichen.” (Or, at least "der Dateiname ist ungültig".

And yes, this bug does not really seam to have a high priority. But I think it would be fairly easy to correct.
Comment 7 steffan.steffner 2019-08-13 14:08:21 UTC
I checked this issue with LibreOffice running on another install of windows 10, also Version 1903, and with the same version of LibreOffice: 6.2.5.2 (x64).

Result: 
On this install, I have the same results as  Oliver Brinzing has had in Comment 2. So it seems that  he had the correct idea in comment 4 that it has got something to do with the Windows OS – and is probably not at all the LibreOffice’s fault .

So, thank you everybody for your time and input. 

If this bug stays open for comments a few more days, maybe I’ll find the time to check on my Windows and I will post here what I found.
Comment 8 Dieter 2019-08-27 19:33:04 UTC
(In reply to steffan.steffner from comment #7)
> If this bug stays open for comments a few more days, maybe I’ll find the
> time to check on my Windows and I will post here what I found.

Stefan, any news about this bug? Shall we leave it open or shall we close it?

=> NEEDINFO
Comment 9 steffan.steffner 2019-08-28 03:54:59 UTC
Also, ich habe jetzt doch noch überprüft, woran es liegen könnte (und bin auch fündig geworden ..)

Ein Hinweis für mich war, dass sich mein WORD 2016 genauso verhält, wie das LibreOffice das auch soll (also so, wie hier in Comment 1 beschrieben).

Also z.B.
T?ES:T - Der Dateiname ist ungültig.
::TEST - Ungültige Klassenzeichenfolge

Das hat mich auf die Idee gebracht, dass alte Versionen von LibreOffice „schuld“ sein könnten. Ich habe also mein LibreOffice 6 deinstalliert, und auch alle alten Ordner manuell gelöscht, also

C:\Program Files\LibreOffice 5
C:\Program Files (x86)\LibreOffice 5
C:\Users\xxxxx\AppData\Roaming\LibreOffice

und dann die neueste Version: 6.3.0.4 (x64) installiert:

Ergebnis: jetzt ist bei mir ebenfalls alles so, wie in Comment 1 beschrieben.

Zumindest könnte das als Information für den Benutzersupport brauchbar sein, wobei es sicherlich dort keine Neuigkeit ist, dass das komplette Löschen aller alten Dateien eines Programms bisweilen  Probleme / unerwünschtes Verhalten beseitigen kann ...
Comment 10 steffan.steffner 2019-08-28 04:17:59 UTC
Sorry, wrong language, so here goes again, same comment in English
(by the way, is there a editung function for comments on bugzilla ??)

I finally found time to check what the reason for my problems might be (and I was successful)

A hint was that my WORD 2016 behaves exactly as LibreOffice should  (that is, as described here under Comment 1.

e.g.
T?ES:T - Der Dateiname ist ungültig.
::TEST - Ungültige Klassenzeichenfolge

This led me to believe that remains of older versions of LibreOffice might be responsible. So I deinstalled my current version of LibreOffice, and then I deleted all remaining folders I could find.

I deleted

C:\Program Files\LibreOffice 5
C:\Program Files (x86)\LibreOffice 5
C:\Users\xxxxx\AppData\Roaming\LibreOffice

and then I installed the new version  6.3.0.4 (x64):

Result: behaviour is now exactly as described under comment 1.

Maybe this could at least be useful for the user support department – even though it might not really be a novelty that deleting all old files and folders of a programs is actually helpful in some cases.