Bug 126821 - Linked cell path broken when saving xlsx file
Summary: Linked cell path broken when saving xlsx file
Status: RESOLVED DUPLICATE of bug 87973
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Reference
  Show dependency treegraph
 
Reported: 2019-08-11 11:50 UTC by Glen A.
Modified: 2020-12-22 13:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Calc with cell reference to another drive (12.30 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-02 08:52 UTC, NISZ LibreOffice Team
Details
The example file saved as XLSX in Calc 7.1 alpha (6.59 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-11-02 08:53 UTC, NISZ LibreOffice Team
Details
The original example ODS and its XLSX save side by side (86.70 KB, image/png)
2020-11-02 08:54 UTC, NISZ LibreOffice Team
Details
The same cell references created in Excel 2013 (10.26 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-11-02 08:55 UTC, NISZ LibreOffice Team
Details
The Excel-made file in Excel 2013 and Calc (100.30 KB, image/png)
2020-11-02 08:56 UTC, NISZ LibreOffice Team
Details
The Excel-made file saved in Calc 7.1 alpha (6.95 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-11-02 08:57 UTC, NISZ LibreOffice Team
Details
Cell reference target files used by the examples (12.61 KB, application/x-zip-compressed)
2020-11-02 09:01 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Glen A. 2019-08-11 11:50:24 UTC
Description:
I create a link to another xlsx file, and it works, with a reference like:

='file:///D:/Documents/Tax/test1.xlsx'#$Sheet1.A1

Then I save the file, close it, and reopen it, and the reference is changed to:

='file:///D:/Documents/Tax/3'#$Sheet1.A1

Why?

Steps to Reproduce:
1. Create a link to a cell in another xlsx document.
2. Save the file, close it, and reopen it.
3. Observe that the reference is now broken.

Actual Results:
The reference URI is broken.

Expected Results:
The reference URI is not broken.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.3.0.4 (x64)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 6; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-ZA (en_ZA); UI-Language: en-US
Calc: CL
Comment 1 m.a.riosv 2019-08-11 11:59:36 UTC
Seems a duplicate.

*** This bug has been marked as a duplicate of bug 76047 ***
Comment 2 NISZ LibreOffice Team 2020-11-02 08:52:16 UTC
Created attachment 166921 [details]
Example file from Calc with cell reference to another drive

I created an example file to demonstrate this problem.

- I placed two simple files to D:\extfile-ref and created cell references to them like
='file:///D:/extfile-ref/EDATAE13_C.xls'#$Munka1.A1

This is retained correctly in ODS format.
Comment 3 NISZ LibreOffice Team 2020-11-02 08:53:35 UTC
Created attachment 166922 [details]
The example file saved as XLSX in Calc 7.1 alpha

Cell reference on XLSX export turns into:

=[4]munka1!a1

Excel detects this as invalid contents.
Comment 4 NISZ LibreOffice Team 2020-11-02 08:54:34 UTC
Created attachment 166923 [details]
The original example ODS and its XLSX save side by side
Comment 5 NISZ LibreOffice Team 2020-11-02 08:55:10 UTC
Created attachment 166924 [details]
The same cell references created in Excel 2013
Comment 6 NISZ LibreOffice Team 2020-11-02 08:56:46 UTC
Created attachment 166925 [details]
The Excel-made file in Excel 2013 and Calc

When the same cell references are created in Excel and opened in Calc that works just fine.
Comment 7 NISZ LibreOffice Team 2020-11-02 08:57:47 UTC
Created attachment 166926 [details]
The Excel-made file saved in Calc 7.1 alpha

Even more interestingly the Excel-made file is correctly roundtripped by Calc in:

Version: 7.1.0.0.alpha1+ (x64)
Build ID: ec1f4d3253963ac16d638734ac70dde033e82154
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 8 NISZ LibreOffice Team 2020-11-02 09:00:21 UTC
Back to NEW: this is clearly not a duplicate, as that one is about connections to external files, while this is about cell references to files on different Windows drives.
I placed my example files to my user directory on C:\ and the targets to D:\ (a pendrive).
Comment 9 NISZ LibreOffice Team 2020-11-02 09:01:41 UTC
Created attachment 166927 [details]
Cell reference target files used by the examples
Comment 10 NISZ LibreOffice Team 2020-12-22 13:10:01 UTC
After retesting this and consulting with Attila, what I saw is likely a duplicate to bug #87973

Simply saving the example file from comment #2 does not reproduce the problem, however the uploaded xlsx from comment #3 shows the same symptom that was fixed in the aforementioned bug.

*** This bug has been marked as a duplicate of bug 87973 ***