Download it now!
Bug 126858 - Calc don't know about Calculated fields in XLSX Pivot table
Summary: Calc don't know about Calculated fields in XLSX Pivot table
Status: RESOLVED DUPLICATE of bug 78486
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Pivot-Table-XLSX
  Show dependency treegraph
 
Reported: 2019-08-12 18:07 UTC by Roman Kuznetsov
Modified: 2019-09-05 21:53 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
XLSX with Calculated field in the pivot table (12.71 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-08-12 18:09 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-08-12 18:07:41 UTC
Description:
Calc don't know about Calculated fields in XLSX Pivot table

Steps to Reproduce:
1. Open XLSX file from attach
2. Go to Sheet 2
3. You'll see empty pivot table instead sum of "Стоимость" field
4. Open file in Excel and comparize pivot table with Calc => there is field "Стоимость" in list of pivot table fields in Excel

Actual Results:
Calc don't know about Calculated fields in XLSX Pivot table and we have lost data

Expected Results:
Calc knows about Calculated fields in XLSX Pivot table and open these files fine


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x64)
Build ID: a9885aed4ee65067613e5506771b6ae6b5e0bae0
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-07-04_01:38:09
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2019-08-12 18:09:31 UTC
Created attachment 153325 [details]
XLSX with Calculated field in the pivot table
Comment 2 raal 2019-08-12 18:30:38 UTC
Confirm with Version: 6.4.0.0.alpha0+
Build ID: 2812610f4f39ed5892da08864893c758325d1d39
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
and Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 3 m.a.riosv 2019-08-12 22:25:22 UTC

*** This bug has been marked as a duplicate of bug 78486 ***
Comment 4 Roman Kuznetsov 2019-08-13 04:48:19 UTC
I think it's two different things: new feature in Calc and problem with XLSX kmport filter. Let's will be to have two different tickets.
Comment 5 m.a.riosv 2019-09-05 21:53:11 UTC

*** This bug has been marked as a duplicate of bug 78486 ***