Bug Hunting Session
Bug 126895 - Text alignment "Justified" last line "start" not honored in outline
Summary: Text alignment "Justified" last line "start" not honored in outline
Status: RESOLVED DUPLICATE of bug 68486
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-13 20:31 UTC by Bob
Modified: 2019-08-20 21:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot of 2-column paper (32.99 KB, image/png)
2019-08-13 20:31 UTC, Bob
Details
Sample .odt file (58.88 KB, application/vnd.oasis.opendocument.text)
2019-08-14 14:52 UTC, Bob
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob 2019-08-13 20:31:15 UTC
Created attachment 153358 [details]
Screen shot of 2-column paper

See attachment.  I'm trying to write a 2-column research paper in outline format.  I want Justified.  Yet the last line of every paragraph is ruined, even though Last Line is set to Start.  The text is in outline format.  It doesn't even recognize the last line of a numbered section to be the end of a paragraph.  The attachment is a horizontal slice of a 2-column research paper.  Note how in the left column, spacing is horrible in last line of paragraph.  New paragraph was created with Shift-Enter, the only way I know to start a new paragraph in an outline without it striking a new outline number. (No other way to insert a "new paragraph" indication.)  Now look at the right column.  Surely, the end of a numbered outline section should be considered to be the end of a paragraph, yet it isn't.

Running on MacOS 10.13.6, High Sierra.
Comment 1 Jean-Baptiste Faure 2019-08-13 20:36:18 UTC
Please, could you attach a test file showing the problem ?

Status set to NEEDINFO; please set it back to UNCONFIRMED once requested
information is provided.

Best regards. JBF
Comment 2 Bob 2019-08-14 13:43:57 UTC
I don't know what you mean by a test file.  I had attached a screen shot exhibiting the problem.  If something else is needed, could you be more specific?  Thanks.
Comment 3 Bob 2019-08-14 13:45:32 UTC
Ahh, now it's clear to me that you probably want a complete, loadable file exhibiting the problem.  It is forthcoming.
Comment 4 Bob 2019-08-14 14:52:35 UTC
Created attachment 153388 [details]
Sample .odt file

Apologies for the obfuscation.
Comment 5 Bob 2019-08-14 15:12:26 UTC
Notes on .odt file.
I am trying to implement the common research paper format of two column text with a synopsis at the top. Note that the synopsis section (done by placing paragraph inside the first-page header) correctly flows the last line.  The remainder of the paper is an outline.
The only way I could find to implement paragraphs in an outline section (without creating a new outline section number) is to use shift-enter.  However this is not recognized as a paragraph.  Note the end of the first paragraph in the 2nd column of page 1.  The last line is Justified even though "Last line" is set to Start.
Note the one-line header titles on outline sections 3, 4, or 6.  It doesn't see these as the end of a paragraph either.  This renders Justified useless in an outline.  I either have to give up Justified, or give up outlines, to get the text to flow in a reasonable way.  Thinking about it now, I have not tested this outside of multi-column format, so I suppose that could be the possible culprit.

From a design philosophy point of view, the thing to keep in mind is that a paragraph is a visual indication, not a logical one.  The dictionary I have at hand says that a paragraph is, "...indicated by a new line, indentation, or numbering."  Note that the definition says, "new line" and not "newline," the point being that it is a visual indication.  I don't see LibreOffice honoring this.
Thanks for all that you do!
Comment 6 Jean-Baptiste Faure 2019-08-15 14:44:40 UTC
Thank you for your test file. It shows that it is not a bug but that there is 2 problems in your text document:
1/ You do not use heading styles (heading 1, heading 2, etc.) for the layout;
2/ You use Shift+Enter to start a new paragraph but that does not do that, that continue the current paragraph on a new line. To start a new paragraph you must use Enter.
Hit Ctrl+F10 to show non-printing characters.

Please have a look at https://wiki.documentfoundation.org/Documentation/Publications#LibreOffice_Writer_Guide
and mainly at chapters 8 (Introduction to Styles) and 9 (Working with Styles).

To rebuild your document, you should:
a/ remove all direct formatting : Ctrl+A > right click > remove direct formatting
b/ remove your numbering
c/ replace each newline mark (Shift+Enter) by a paragraph mark (Enter)
d/ Apply "Heading 1" style to each section title
e/ customize the Heading 1 style to add a numbering to it : menu Tools > Chapter numbering

For normal text, you should use "Text Body" style instead of "Default Style" style.

If you still have difficulty, please ask for help on users mailing list (users@global.libreoffice.org) or on AskLibo (https://ask.libreoffice.org).

Closing as NotABug.

Best regards. JBF
Comment 7 Bob 2019-08-15 19:31:09 UTC
Thank you for the detailed response.  I will look into this for the sample document.  However, it looks like you've come up with a work-around for this particular use case.  Yes I could use headings for this document.  But the problem I'm reporting is that it seems "Last line" for Justify cannot work in outlines.  It is not unreasonable to have more than one paragraph in one numbered outline section, and using shift-enter seems the only way to do that in an outline without creating a new section.  It doesn't seem like what you are suggesting will fix that problem.
Philosophically we could say it's not a bug, but it would certainly be a deficiency to say that Justify with Last line left-justified cannot work in a multi-paragraph outline section.  Again philosophically, we could say that an outline section is considered one paragraph no matter what, and therefore Write is behaving properly, but that doesn't serve the visual definition of a paragraph.  And if this is the case, perhaps as a feature request there could be the notion of a "new paragraph" insert.  Thanks for listening.
Comment 8 eisa01 2019-08-20 21:46:51 UTC
This seems to be listed as a requested enhancement already

*** This bug has been marked as a duplicate of bug 68486 ***