Download it now!
Bug 126924 - Base Upgrade 6.3.0 From 6.2.5 (Firebird from hsqldb) Issues
Summary: Base Upgrade 6.3.0 From 6.2.5 (Firebird from hsqldb) Issues
Status: RESOLVED DUPLICATE of bug 126268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-14 13:45 UTC by Brent Warkentin
Modified: 2019-08-20 09:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample database (18.17 KB, application/vnd.sun.xml.base)
2019-08-14 14:23 UTC, Brent Warkentin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Warkentin 2019-08-14 13:45:32 UTC
Description:
Database had four tables... Followed the notes to convert dates to text in each table... ran upgrade utility... DOUBLE Fields did not process... Reloaded another back up and converted dates and DOUBLE to text and then ran utility and converted fine...  BUT one table lost 200 or so records that just disappeared... Ran out of time, so reloaded back to 6.2.5 to continue database use... will try again when I have more time...

Steps to Reproduce:
1. Process Base Table Upgrade to Firebird
2.
3.

Actual Results:
See above in description field....

Expected Results:
Lost 200 table records....


Reproducible: Always


User Profile Reset: No



Additional Info:
Process all tables properly....
Comment 1 Xisco Faulí 2019-08-14 14:06:24 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Brent Warkentin 2019-08-14 14:23:08 UTC
Created attachment 153387 [details]
Sample database

This is as sample database with only 2 tables... the two tables would have the same # of records 358 normally... but the Invoice table only coverted 158 records... 

No data is included... just an anonymous sample....
Comment 3 Brent Warkentin 2019-08-15 22:46:07 UTC
Added testing...

1. Stopping of the upgrade utility and missing rows of data was linked to a data format error in one field..  When corrected the upgrade ran to completion..

2. The utility dd NOT process DOUBLE format... had to follow similar steps as for DATE fields...  ie. Copy as text VARCHAR, run upgrade and copy back...

3. Confirm that query and sub form setting in content.xml fix was needed to allow for my queries and forms to work...
Comment 4 Alex Thurgood 2019-08-16 12:40:59 UTC
@Brent : the double conversion issue (or failure thereof) should have been resolved in bug 126268 for LO6302

*** This bug has been marked as a duplicate of bug 126268 ***
Comment 5 Alex Thurgood 2019-08-16 12:46:46 UTC
@Brent : if the double conversion/migration issue is indeed a problem, then bug 126268 would need to be reopened.
Comment 6 Xisco Faulí 2019-08-19 06:02:59 UTC
Hello Brent,
I've just opened your file, it only contains 1 row in each table.
Please attach the correct file, Even in HSQLDB
Comment 7 Brent Warkentin 2019-08-19 15:32:52 UTC
The data in the database is proprietary and will not be posted, open to the Internet...

The database structure is as posted with one sample record... add whatever you need to test...