Bug 126954 - Image cropping bug in Writer 6.2.5.2 if opened on another system
Summary: Image cropping bug in Writer 6.2.5.2 if opened on another system
Status: RESOLVED DUPLICATE of bug 102296
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Image-DPI
  Show dependency treegraph
 
Reported: 2019-08-15 19:41 UTC by Marcellus Wallace
Modified: 2020-03-23 17:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODT with incorrectly cropped pictures (722.15 KB, application/vnd.oasis.opendocument.text)
2019-08-15 19:42 UTC, Marcellus Wallace
Details
ODT original with cropped images (722.66 KB, application/vnd.oasis.opendocument.text)
2019-11-15 17:46 UTC, Timur
Details
PDF of attachment 155857 (727.40 KB, application/pdf)
2019-11-17 06:55 UTC, Dieter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcellus Wallace 2019-08-15 19:41:04 UTC
Description:
I cropped and resize an image in Writer on my desktop. The file looked good.
Then I opened it in my laptop and I saw that the cropping of every image was incorrect. I fixed it with my laptop, saved and closed. I reopened it, everything was fine. I reopened it with my desktop and bad cropping was here again, it still was present on a virtualized Xubuntu.
It's always the same file, opened from the same place, a shared folder.
Desktop (Win10 up to date), Laptop (Win10 up to date) and virtualized Xubuntu (19.04 up to date) has the same LibreOffice version : 6.2.5.2 
Here, you'll find a video of what I see : https://www.youtube.com/upload

Steps to Reproduce:
1. Open the file
2. look at the pictures
3.

Actual Results:
pictures aren't correctly cropped when file is opened on another computer

Expected Results:
The document should be identical


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
I already experienced such cropping problems in previous LibreOffice versions.
Comment 1 Marcellus Wallace 2019-08-15 19:42:10 UTC
Created attachment 153422 [details]
ODT with incorrectly cropped pictures
Comment 2 Marcellus Wallace 2019-08-15 23:35:06 UTC Comment hidden (obsolete)
Comment 3 Dieter 2019-08-20 15:58:30 UTC Comment hidden (obsolete)
Comment 4 Marcellus Wallace 2019-08-20 22:34:29 UTC
Hello,
Sorry, here is the new link to the video : https://youtu.be/CyTyU5KFYwg
I found a previous version of the same file, which displayed correctly on my desktop. I uploaded the 2 version on my website : http://bernon.fr/uploads/cropping_bug/
there is a picture of these 2 files opened simultaneously with Win10 and Xubuntu 19.04 : 4 differently displayed images... (http://bernon.fr/uploads/cropping_bug/libreoffice%20cropping%20bug.jpg )
Comment 5 Timur 2019-11-15 17:46:51 UTC
Created attachment 155857 [details]
ODT original with cropped images

Any bug makes sense only if there are reproducible steps so that issue can be confirmed. 
Here is ODT original with cropped images from web page.
Comment 6 Dieter 2019-11-17 06:55:24 UTC
Created attachment 155886 [details]
PDF of attachment 155857 [details]

I can't confirm it with

Version: 6.4.0.0.beta1 (x64)
Build ID: 4d7e5b0c40ed843384704eca3ce21981d4e98920
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

I opened attachment 155857 [details] and everything looks fine.
Comment 7 Timur 2020-03-23 17:39:39 UTC
I guess we may consider this a duplicate of bug 102296.
If you have something to add, please write there.
If you fully disagree, please explain.

*** This bug has been marked as a duplicate of bug 102296 ***