Bug 126966 - Sidebar: color selection too small for finger usage
Summary: Sidebar: color selection too small for finger usage
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: iOS Editor (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other iOS
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-16 09:17 UTC by Nicolas Christener
Modified: 2020-05-18 14:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Printscreen showing the issue (676.26 KB, image/png)
2019-12-13 17:58 UTC, Nicolas Christener
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Christener 2019-08-16 09:17:01 UTC
Description:
The sidebar in writer on iOS contains at least three color selection widgets which are too small to be useful in a touch only environment:
* font color
* highlight color
* background color

I believe, that the entire "color selection"-dialog needs to be improved for iOS:
* clicking the color palette selection makes the dialog disappear
* the existing color palettes ("custom" and "document colors") are mostly useless because they don't contain any colors
* the "recent" colors are way too small to be used with a finger
* the "custom color..." button doesn't do anything

There's a slightly better dialog which is called "pick a color" and can be called from the "paragraph style" dialog > area > color > pick.

Maybe we could use the same dialog as an initial solution?

Steps to Reproduce:
1. Open the sidebar in iOS
2. Tap the button to change the font color

Actual Results:
It's almost impossible to use the dialog with a finger.

Expected Results:
It should be easy to use the dialog with a finger.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tor Lillqvist 2019-08-30 09:21:59 UTC
Looking at this now.
Comment 2 Tor Lillqvist 2019-08-30 10:26:54 UTC
Turns out the share/palette folder was missing from the iOS app. Adding that makes the colour selection sidebar in the iOS app a bit saner (makes it look & behave more like in normal Online). Doesn't affect the size of UI elements, though. Fix in https://gerrit.libreoffice.org/#/c/78288/ .
Comment 3 Tor Lillqvist 2019-08-30 10:37:54 UTC
The weird behaviour of the colour selection button in the "Character" part of the sidebar happens in normal Online too. At least to me its behaviour seems a bit odd and it requires too much clicking to show up again after you change the palette.
Comment 4 Tor Lillqvist 2019-08-30 10:50:52 UTC
Compare to desktop sidebar: changing the palette in the combobox just does that, the widget with the array of colours doesn't go away, the colours just change.
Comment 5 Commit Notification 2019-08-30 11:29:02 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d418eaed304d69f5a766a9ee5a907a71771b0223%5E%21

tdf#126966: The share/palette folder was missing from the iOS app

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Tor Lillqvist 2019-08-30 15:03:42 UTC
Another change, to increase the size of these controls in the sidebar on iOS: https://gerrit.libreoffice.org/#/c/78303/
Comment 7 Tor Lillqvist 2019-08-30 21:28:26 UTC
Sadly the above change won't apply as such to the master branch, as the code for ToolboxButtonColorUpdater::Update() is totally different there. But at least the size changing bits of it should be done to master soonish, the centering of the artwork can be done later.
Comment 8 Tor Lillqvist 2019-09-16 19:05:42 UTC
Argh, that change (57255d4bc47dcabdcc0734d564059326910c5609 , in comment #6) was too simple, it doesn't work properly. A colour selection control does get larger, but after it has been used once, it disappears completely. Investigating more.
Comment 9 Tor Lillqvist 2019-09-16 19:49:36 UTC
First attempt will be reverted: https://gerrit.libreoffice.org/#/c/79027/
Comment 10 Marco Cecchetti 2019-09-24 15:30:24 UTC
A new attempt is available here:
https://gerrit.libreoffice.org/#/c/79468/

Tor's patch was not so far from being the right solution. :-)

Anyway this is a minimal fix.
The patch increase the size of color controls in the sidebar on iOS.
Comment 11 Commit Notification 2019-11-01 19:37:30 UTC
Marco Cecchetti committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/467429fe1dd0a7ab62e90234d71c3809ab270159

tdf#126966: Use larger buttons for the colours in the sidebar on iOS - 2

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2019-12-03 10:47:54 UTC
A polite ping to Marco Cecchetti:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 13 Nicolas Christener 2019-12-13 17:56:17 UTC
This bug is (again) present in 4.2 (25).

I believe it is a regression as it worked in 4.1.x.

@Tor: can you check this please?
Comment 14 Nicolas Christener 2019-12-13 17:58:39 UTC
Created attachment 156565 [details]
Printscreen showing the issue
Comment 15 Tor Lillqvist 2019-12-20 13:08:39 UTC
Nicolas, what you have marked in the print screen in your previous comment, the array of square colour swatches, looked exactly the same in 4.1.73. That aspect of this bug was not fixed during the 4.1 series. What was made larger were the controls used to open up that array of colour swatches. (But also that has changed a bit unintentionally; the bar with the selected colour below such a control is not there any longer.)
Comment 16 Commit Notification 2019-12-20 14:25:09 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2fdd5dd95777c8352d390beed11f4a969f0baadf

tdf#126966: Tweak to get the "color bar" below text color controls to show up

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Tor Lillqvist 2019-12-20 15:57:13 UTC
Have been working on making the colour squares larger (and fewer per line). Almost works now, except that the colour that gets selected is not the one you tap on, but the one below. Or something like that.

Another issue is that the box with the palette can't be scrolled, even if a scrollbar is displayed.
Comment 18 Tor Lillqvist 2019-12-20 16:13:35 UTC
Ah, the problem with the wrong colour getting selected was just that the swatches were still too small for finger use. I made them even larger and now I can hit the intended one fairly reliably. https://gerrit.libreoffice.org/85620
Comment 19 Commit Notification 2019-12-21 03:06:09 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6c3f6fc13a9d6d112253f895d45ea4c9aaab6607

tdf#126966: Make the colour swatches larger on iOS

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Nicolas Christener 2020-05-18 14:15:45 UTC
Tested with 4.2.4 (55).

The issue has been fixed an I believe we can close this issue.

Thanks a lot to the Collabora team and especially Tor for taking care of this!