Bug 126996 - FILESAVE DOCX The wideslash from a formula is not saved
Summary: FILESAVE DOCX The wideslash from a formula is not saved
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Formula
  Show dependency treegraph
 
Reported: 2019-08-17 17:56 UTC by hmslima1992
Modified: 2022-04-25 17:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Files used in the test (1.97 MB, application/zip)
2019-08-17 17:56 UTC, hmslima1992
Details
Files used in the test. Pay attention to the file names, they are descriptions (44.91 KB, application/zip)
2019-08-24 13:32 UTC, hmslima1992
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hmslima1992 2019-08-17 17:56:57 UTC
Created attachment 153468 [details]
Files used in the test

In a .docx document created by Microsoft Office 2013 and opened by LibreOffice: the "wideslash" from a formula is converted to a `over` (horizontal bar) division line.

In a .docx document created by Microsoft Office 2013, then edited by LibreOffice and finally reopened by Microsoft Office 2013: the "wideslash" is replaced for a horizontal bar

In a .docx document created by LibreOffice and opened by Microsoft Office 2013: the "wideslash" disappeared, so numerator and denominator are together
Comment 1 hmslima1992 2019-08-24 13:32:52 UTC
Created attachment 153621 [details]
Files used in the test. Pay attention to the file names, they are descriptions

I decided to bring here more-clear files. It's just the formula showing a wideslash and a wideBslash (in Microsoft Office it is called "Skewed Fraction"). The files are:

(1) Formula.odt = the original file created by LibreOffice 6.3. Microsoft Office 2013 is able to visualize the wideslash, but seems to me that Microsoft Office 2013 "converts" the wideBslash to a simple "\" character (what obviously is not the fault of LibreOffice since Microsoft Office apparently is not able to create the equivalent of a wideBslash)

(2) Formula (created by LibreOffice 6.3).docx = the .docx file exported from the previous one. The division line is gone (for both LibreOffice and Microsoft Office), it simply shows "(xy) = (xy)".

(3) Formula (created by LibreOffice 6.3 and tried to be corrected by this same program).docx = a copy from the previous file, here I tried to re-add the wideslash and the wideBslash by LibreOffice 6.3 itself, but when I open the document again, the division line are all gone even for LibreOffice!

(4) Formula (created by LibreOffice 6.3 and tried to be corrected by Microsoft Office 2013).docx = a copy of the file (2). The corrections of this file made by Microsoft Office remains. When I try to open this file with LIbreOffice 6.3, I get the same result of when I try to open the file (5)

(5) Formula (created by Microsoft Office 2013).docx = when I open this file with LibreOffice, instead of LibreOffice to show wideslashs, it shows me normal fraction lines (those ones that we see when we use the "over" definition in the Formula Editor)

(6) Formula (created by Microsoft Office 2013 and edited by LibreOffice 6.3).docx = I just added a letter to the document, deleted this letter and then saved the document; only it, theoretically it has to be the very same thing of the previous file. I even didn't touch the formula! When I open it in Microsoft Office 2013, the wideslashs were replaced by those normal-horizontal-division lines (the ones that we get when we use the "over" definition in the Formula Editor)

.

I noted that while the file (5) has the size of 12.2 KiB while the file (6) has the size of 9.4 KiB. Theoretically these two files should be identical, but there was a loss of information.
Comment 2 Xisco Faulí 2019-09-24 11:07:42 UTC
Thanks for reporting this issue.
I see many documents in the zip file. Which is the one we have to use in order to find the incorrect behaviour ?
Comment 3 hmslima1992 2019-09-25 19:48:24 UTC
First of all, you need to understand the problem. Well, the document should contain a `wideslash` and a `wideBslash` (I strongly suggest you to open the file "Formula.odt" to see the formula in its normal state). The problem is:

* LibreOffice cannot create (and neither properly read) a `wideslash` in a DOCX document.

* About the `wideBslash`, Microsoft Office does not support it in its own documents, you can IGNORE this feature!! Actually I regret putting this in the document... only focus in the normal `wideslash`, forget the `wideBslash`!

.

There is a description for all files in my previous comment, but if you wanna see only a few of them, then check the three original files listed below:

(1) "Formula.odt" = just the original and normal ODT file, only for you to see how the document is supposed to behave

(2) "Formula (created by LibreOffice 6.3).docx" = here you already see the problem! There is no wideslash for both LibreOffice and Microsoft Office.

(3) "Formula (created by Microsoft Office 2013).docx" = LibreOffice is no able to correctly display the wideslash created by the Microsoft Office. Instead of showing a `wideslash`, LibreOffice a horizontal bar.

* If you wanna know what happens when one of these documents are edited, read my previous comment, where I tell what happens after these editions. All of those files are just phases of sucessive modifications.


.

.

In short, LibreOffice cannot handle `wideslashs` in DOCX documents.

.
Comment 4 Buovjaga 2020-04-24 19:22:05 UTC
Repro by saving Formula.odt to .docx and reopening. Same with 3.5.0, 4.4.7 and 5.4.0. Version 3.3.0 loses the formula completely.

Arch Linux 64-bit
Version: 7.0.0.0.alpha0+
Build ID: 6a9c7409ee617b79c327dd7ea4de432f448b6006
CPU threads: 8; OS: Linux 5.6; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 24 April 2020
Comment 5 QA Administrators 2022-04-25 03:26:43 UTC Comment hidden (obsolete)
Comment 6 hmslima1992 2022-04-25 17:42:13 UTC
(In reply to QA Administrators from comment #5)
> Dear hmslima1992,
> 
> To make sure we're focusing on the bugs that affect our users today,
> LibreOffice QA is asking bug reporters and confirmers to retest open,
> confirmed bugs which have not been touched for over a year.
> 
> There have been thousands of bug fixes and commits since anyone checked on
> this bug report. During that time, it's possible that the bug has been
> fixed, or the details of the problem have changed. We'd really appreciate
> your help in getting confirmation that the bug is still present.
> 
> If you have time, please do the following:
> 
> Test to see if the bug is still present with the latest version of
> LibreOffice from https://www.libreoffice.org/download/
> 
> If the bug is present, please leave a comment that includes the information
> from Help - About LibreOffice.
>  
> If the bug is NOT present, please set the bug's Status field to
> RESOLVED-WORKSFORME and leave a comment that includes the information from
> Help - About LibreOffice.
> 
> Please DO NOT
> 
> Update the version field
> Reply via email (please reply directly on the bug tracker)
> Set the bug's Status field to RESOLVED - FIXED (this status has a particular
> meaning that is not 
> appropriate in this case)
> 
> 
> If you want to do more to help you can test to see if your issue is a
> REGRESSION. To do so:
> 1. Download and install oldest version of LibreOffice (usually 3.3 unless
> your bug pertains to a feature added after 3.3) from
> https://downloadarchive.documentfoundation.org/libreoffice/old/
> 
> 2. Test your bug
> 3. Leave a comment with your results.
> 4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
> 4b. If the bug was not present in 3.3 - add 'regression' to keyword
> 
> 
> Feel free to come ask questions or to say hello in our QA chat:
> https://web.libera.chat/?settings=#libreoffice-qa
> 
> Thank you for helping us make LibreOffice even better for everyone!
> 
> Warm Regards,
> QA Team
> 
> MassPing-UntouchedBug

The problem persists. When I convert the ODT document to DOCX, the wideslashes are completely lost.

Remember that Microsoft Office doesn't have a perfect equivalent for wideBslash, but you could replace it for a common division line (like we do in `{<?>} over {<?>}` in LibreOffice) or even re-use the wideslash like ONLYOFFICE does, although LibreOffice currently is not able to export its wideslash to a DOCX document...

However, the Microsoft's office suite do have a perfect equivalent for wideslash, so you should solve that.

By the way, I don't know where you test the files, just know that online Microsoft Office cannot correctly render the wideslashes created by the own offline Microsoft Office, I hope you guys are testing the documents in an offline version of Microsoft Office.


Version: 7.3.1.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: pt-BR
Debian package version: 1:7.3.1-1~bpo11+1
Calc: threaded