Bug 127001 - FILEOPEN DOCX: In a .docx file created by Microsoft Office 2013, a second section appears after a "Two Columns" section
Summary: FILEOPEN DOCX: In a .docx file created by Microsoft Office 2013, a second sec...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Section
  Show dependency treegraph
 
Reported: 2019-08-17 19:01 UTC by hmslima1992
Modified: 2019-09-02 18:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Files used in the test (1.97 MB, application/zip)
2019-08-17 19:01 UTC, hmslima1992
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hmslima1992 2019-08-17 19:01:00 UTC
Created attachment 153469 [details]
Files used in the test

Probably it's not a big problem since appearly it has no negative effect, but it's visually unpleasant and perhaps it can create real problem in more complex documents.
Comment 1 Dieter 2019-08-23 15:58:24 UTC
I can confirm this.

As you can see in sidebar this frame indicates a section section, that is added, when you open the file in LO

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

and in

Version: 5.4.7.2 (x64)
Build-ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU-Threads: 4; BS: Windows 6.19; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 2 Justin L 2019-09-02 18:04:57 UTC
Writer doesn't have the concept of a continuous break, so it has to emulate that with sections. Word combines page styles and section settings into a single concept, but writer has them distinctly separated. Since the emulation is working without a negative effect, I'm marking this as won't fix. This is an EXTREMELY tricky area to deal with and has lots of bug reports.  (see bug 81426 for example.)