Bug 127018 - horizontal scrolling is reversed libre office 6.3 macos high sierra
Summary: horizontal scrolling is reversed libre office 6.3 macos high sierra
Status: RESOLVED DUPLICATE of bug 126680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-19 05:39 UTC by wwohlsein
Modified: 2019-08-19 05:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wwohlsein 2019-08-19 05:39:18 UTC
Description:
scrolling is a system wide feature in macos.

with libreoffice 6.3 horizontal scrolling workes opposite to system wide standard

horizontal scrollbar moves in 
SAME direction as gesture with natural scrolling enabled
OPPOSITE direction to gesture with natural scrolling disabled

Steps to Reproduce:
1. in mac os high sierra go to system preferences/trackpad/zoom & scroll
2. enable / disable natural scrolling
3. scroll horizontally in any libreoffice document

Actual Results:
scroll gesture to move to the right (two fingers move) works inversed to the standard behavior set by operating system:
i have natural scrolling disabled so i expect the scrollbar to move in the same direction as my gesture both horizontally and vertically.
in previous versions of libreoffice that behavior was consistent, now only vertical scrolling works as expected.


Expected Results:
natural scrolling disabled in system preferences should make scrollbar move in same direction as scroll gesture to maintain consistency with system wide program behavior.


Reproducible: Always


User Profile Reset: No



Additional Info:
macos high sierra (and probably other macos versions) knows TWO general directions of scrolling (system preferences/trackpad/scroll & zoom)

natural enabled (scrollbar - both vertical & horizontal - moves in OPPOSITE direction of scrolling gesture)
natural disabled (scollbar moves in SAME direction as scrolling gesture)

this behavior is consistent through all programs used in macos high sierra

after installing libre office 6.3 HORIZONTAL SCROLLING is reversed

horizontal scrollbar now moves in
SAME direction with natural scrolling enabled and
OPPOSITE direction with natural scrolling disabled

as this is inconsistent with expected behavior & system wide functionality, it is clearly a bug.

a similar behavior for windows was reported several years ago: Bug 76017
Comment 1 Buovjaga 2019-08-19 05:49:56 UTC
It is fixed in the to-be-released 6.3.1

*** This bug has been marked as a duplicate of bug 126680 ***