Bug 127079 - horizontal scroll always in wrong direction
Summary: horizontal scroll always in wrong direction
Status: RESOLVED DUPLICATE of bug 126680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-21 10:27 UTC by Emil Prpic
Modified: 2019-08-21 10:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emil Prpic 2019-08-21 10:27:13 UTC
Description:
Whether I use the mouse with horizontal scroll, or two fingers on the trackpad, horizontal scroll always has wrong direction. 
Per example - if in OS setting I choose natural scroll, then vertical scroll IS natural (i.e. rolling the wheel down, the document pans down), but horizontal scroll ISN'T (i.e. rolling the wheel to the left, the document pans right). If in OS setting I don't choose natural scroll, then vertical scroll ISN'T natural (i.e. rolling the wheel down, the document pans up), and horizontal IS natural.

The problem is the same in Calc and in Writer

Steps to Reproduce:
1. open a document in Calc od Writer
2. zoom so that the width of the document doesn't fit in window
3. try to scroll up-down and left-right using a mouse ball/track surface or trackpad surface

Actual Results:
The horizontal scroll always goes the wrong way

Expected Results:
The horizontal scroll should go in the direction chosen in OS settings (natural direction or not natural direction), like vertical scroll does 


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 8; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
Locale: hr-HR (en_HR.UTF-8); UI-Language: en-US
Calc: threaded

THIS FEATURE WORKED FINE IN 6.1.3!
Comment 1 Buovjaga 2019-08-21 10:33:37 UTC

*** This bug has been marked as a duplicate of bug 126680 ***