Download it now!
Bug 127090 - FILESAVE: PPTX: Text in pieWedge shape rotates with shape instead of staying upright
Summary: FILESAVE: PPTX: Text in pieWedge shape rotates with shape instead of staying ...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.5.0 target:6.4.0.1 target:6.3.5
Keywords: filter:pptx
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2019-08-21 23:17 UTC by Gerald Pfeifer
Modified: 2019-11-29 08:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (ODP) (78.49 KB, application/vnd.oasis.opendocument.presentation)
2019-08-21 23:17 UTC, Gerald Pfeifer
Details
This is how it originally looked. (29.15 KB, image/png)
2019-08-21 23:18 UTC, Gerald Pfeifer
Details
And this is how it looks after being exported to PPTX. (33.07 KB, image/png)
2019-08-21 23:18 UTC, Gerald Pfeifer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2019-08-21 23:17:23 UTC
Saving the attached ODP as PPTX and than opening that PPTX (in LO or 365)
suddenly text that used to be horizontal is arbitrarily rotated by 90°,
180°, 270°.
Comment 1 Gerald Pfeifer 2019-08-21 23:17:51 UTC
Created attachment 153561 [details]
Sample document (ODP)
Comment 2 Gerald Pfeifer 2019-08-21 23:18:24 UTC
Created attachment 153562 [details]
This is how it originally looked.
Comment 3 Gerald Pfeifer 2019-08-21 23:18:51 UTC
Created attachment 153563 [details]
And this is how it looks after being exported to PPTX.
Comment 4 Regina Henschel 2019-08-22 20:34:11 UTC
The text does not rotate arbitrarily but follows the shape rotation. The problem is, that LibreOffice does not support the needed attribute "upright" of the <a:bodyPr> element in OOXML. And OOXML does not support the additional text rotation of text inside a custom shape of ODF.

So a proper fix would be to make LibreOffice able to transform the "upright" attribute into a suitable text rotation on import and transform the text rotation back to attribute "upright" on export.

A similar problem exists as bug 104290 for Calc.

I wonder, how you have generated the file. The preset shape "pieWedge" does not belong to shapes, which are available in the UI, neither in LibreOffice nor in PowerPoint. And rotating text inside a custom shape has no UI in LibreOffice.
Comment 5 Gerald Pfeifer 2019-08-22 23:22:27 UTC
(In reply to Regina Henschel from comment #4)
> I wonder, how you have generated the file. The preset shape "pieWedge" does
> not belong to shapes, which are available in the UI, neither in LibreOffice
> nor in PowerPoint. And rotating text inside a custom shape has no UI in
> LibreOffice.

This came from a PPTX I got.  The PPTX to ODP path went surprisingly
okay-ish (no undesired rotations).  Just when then saving as PPTX since
a colleague could not handle the ODP did this materialize.

(Nice analysis, by the way. Thank you!)
Comment 6 Xisco Faulí 2019-09-18 11:35:17 UTC
Also reproduced in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 7 Commit Notification 2019-11-27 20:13:06 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9b2f5d27cf0a0adcced813e18108d5878061d1ee

tdf#127090 Export textbox rotation attribute.

It will be available in 6.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-11-28 07:48:23 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/5b5f58f395d1b6c1d007dcc6dc29535c5678f851

tdf#127090 Export textbox rotation attribute.

It will be available in 6.4.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2019-11-28 09:55:00 UTC
Verified in

Version: 6.5.0.0.alpha0+
Build ID: 2bf687bebb30defe576ddb20c1c9680979ed3086
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Gülşah Köse, thanks for fixing this issue!
Comment 10 Commit Notification 2019-11-29 08:07:26 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/a06884e5967c4ebf730772b25682cf85dd026d50

tdf#127090 Export textbox rotation attribute.

It will be available in 6.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.