Download it now!
Bug 127127 - Support enabling optional smart font features for AAT
Summary: Support enabling optional smart font features for AAT
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 58941 HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2019-08-23 18:14 UTC by Volga
Modified: 2019-08-23 21:27 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2019-08-23 18:14:36 UTC
Description:
Since HarfBuzz got native support for Apple Advanced Typography (AAT), it’s possible to enable or disable font features for AAT fonts, as what we implemented for OpenType and Graphite fonts. This technology has own font feature registery.

See: https://developer.apple.com/fonts/TrueType-Reference-Manual/RM09/AppendixF.html

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Khaled Hosny 2019-08-23 21:27:01 UTC
They are enabled like OpenType features.