Bug Hunting Session
Bug 127161 - Graphite font rendering is not happening in LibreOffice-6 versions
Summary: Graphite font rendering is not happening in LibreOffice-6 versions
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.5.1 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2019-08-26 08:34 UTC by Jayakumar
Modified: 2019-11-13 08:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
It has graphite font characters in combination to get it clear rendering (15.55 MB, application/vnd.oasis.opendocument.text)
2019-08-31 00:49 UTC, Jayakumar
Details
Screenshot before fixing font name (439.02 KB, image/png)
2019-11-02 14:36 UTC, Khaled Hosny
Details
Screenshot after fixing font name (365.79 KB, image/png)
2019-11-02 14:36 UTC, Khaled Hosny
Details
actual rendering looks like (18.95 KB, image/jpeg)
2019-11-04 06:00 UTC, Jayakumar
Details
Additional testing characters (54.73 KB, image/jpeg)
2019-11-04 06:01 UTC, Jayakumar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jayakumar 2019-08-26 08:34:34 UTC
Description:
I am using graphite font. It was working fine with LibreOffice-5.2.4. But it is not rendering properly in latest versions.

Actual Results:
ப𑌼ர்க்கத்தூ ஜனக𑌼ம்பெ𑌼னு யார்ப்பெ𑌼க்கா தக்கெ𑌼னி மேசியாவெ𑌼ன் (Here in firefox it works well)

Expected Results:
ப𑌼ர்க்கத்தூ ஜனக𑌼ம்பெ𑌼னு யார்ப்பெ𑌼க்கா தக்கெ𑌼னி மேசியாவெ𑌼ன்


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter Praas 2019-08-30 12:43:54 UTC
Jayakumar, thank you for reporting the bug. Please add an attachment, that shows problems with rendering.

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it)
Comment 2 Jayakumar 2019-08-31 00:49:25 UTC
Created attachment 153772 [details]
It has graphite font characters in combination to get it clear rendering
Comment 3 Jayakumar 2019-08-31 00:51:13 UTC
(In reply to Dieter Praas from comment #1)
> Jayakumar, thank you for reporting the bug. Please add an attachment, that
> shows problems with rendering.
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' once the requested document is provided.
> (Please note that the attachment will be public, remove any sensitive
> information before attaching it)
Comment 4 Jayakumar 2019-09-19 07:10:49 UTC
Dear Team,
Is there any update on this request can be expected?
Comment 5 Xisco Faulí 2019-10-29 09:47:11 UTC
@Khaled, is it related to the new text layout engine ?
Comment 6 Khaled Hosny 2019-10-29 22:11:36 UTC
I don’t think so. If I open the document the set font is shown in italic with tooltip that it is not available. The font name is “TAML ThiruValluvar Betta Kurumb” which seems to be ,missing an a at the end, changing it to “TAML ThiruValluvar Betta Kurumba” seems to fix the rendering.

Whatever truncated that a (user, software bug) is the culprit here.
Comment 7 Jayakumar 2019-10-30 06:30:41 UTC
(In reply to Khaled Hosny from comment #6)
> I don’t think so. If I open the document the set font is shown in italic
> with tooltip that it is not available. The font name is “TAML ThiruValluvar
> Betta Kurumb” which seems to be ,missing an a at the end, changing it to
> “TAML ThiruValluvar Betta Kurumba” seems to fix the rendering.
> 
> Whatever truncated that a (user, software bug) is the culprit here.

I Tried changing the name into “TAML ThiruValluvar Betta Kurumba” but I could not see the proper rendering.
Comment 8 Khaled Hosny 2019-11-02 14:36:03 UTC
Created attachment 155467 [details]
Screenshot before fixing font name
Comment 9 Khaled Hosny 2019-11-02 14:36:53 UTC
Created attachment 155468 [details]
Screenshot after fixing font name
Comment 10 Khaled Hosny 2019-11-02 14:42:09 UTC
I attached two screenshots before and after fixing the font name.
Comment 11 Jayakumar 2019-11-04 05:22:44 UTC
(In reply to Khaled Hosny from comment #10)
> I attached two screenshots before and after fixing the font name.

Dear Khaled,
The rendering I see in the second screen shot is also not proper.

I will attach one screenshot how it should look like.

Thank You for your support
Jayakumar
Comment 12 Jayakumar 2019-11-04 06:00:08 UTC
Created attachment 155492 [details]
actual rendering looks like

ப𑌼ர்க்கத்தூ ஜனக𑌼ம்பெ𑌼னு யார்ப்பெ𑌼க்கா தக்கெ𑌼னி மேசியாவெ𑌼ன்

rendering in paratext
Comment 13 Jayakumar 2019-11-04 06:01:44 UTC
Created attachment 155493 [details]
Additional testing characters

This screenshot comes from following characters.

 க𑌼ி ட𑌼ி த𑌼ி ப𑌼ி க𑌼ீ ட𑌼ீ த𑌼ீ ப𑌼ீ க𑌼ு ட𑌼ு த𑌼ு ப𑌼ு க𑌼ூ ட𑌼ூ த𑌼ூ ப𑌼ூ க𑌼ெ𑌼 ட𑌼ெ𑌼 த𑌼ெ𑌼 ப𑌼ெ𑌼 க𑌼ே𑌼 ட𑌼ே𑌼 த𑌼ே𑌼 ப𑌼ே𑌼 கெ𑌼 ஙெ𑌼 செ𑌼 ஞெ𑌼 டெ𑌼 நெ𑌼 தெ𑌼 ணெ𑌼 பெ𑌼 மெ𑌼 யெ𑌼 ரெ𑌼 லெ𑌼 வெ𑌼 ளெ𑌼 ழெ𑌼 றெ𑌼 னெ𑌼 கே𑌼 ஙே𑌼 சே𑌼 ஞே𑌼 டே𑌼 நே𑌼 தே𑌼 ணே𑌼 பே𑌼 மே𑌼 யே𑌼 ரே𑌼 லே𑌼 வே𑌼 ளே𑌼 ழே𑌼 றே𑌼 னே𑌼 க𑌼ை ட𑌼ை த𑌼ை ப𑌼ை க𑌼ொ ட𑌼ொ த𑌼ொ ப𑌼ொ ப𑌼் க𑌼்த𑌼்ட𑌼்
Comment 14 Khaled Hosny 2019-11-08 21:31:04 UTC
Ok, I see the difference now and I don’t reproduce it with hb-view from HarfBuzz, so either a bug in our HarfBuzz integration or we are using outdated versions of HarfBuzz and/or Graphite2 libraries.
Comment 15 martin_hosken 2019-11-12 03:55:59 UTC
My take is that this is a run segmentation issue. This is Tamil text, but the offending character is from the Grantha block. The character is supposed to work with Tamil text and is listed in the ScriptExtensions.txt of the UCD. My assumption is that this information hasn't got into libo. Sorry, no time today to dig into that. Firefox does support ScriptExtensions correctly in its segmenting.
Comment 16 Khaled Hosny 2019-11-12 23:11:32 UTC
(In reply to martin_hosken from comment #15)
> My take is that this is a run segmentation issue. This is Tamil text, but
> the offending character is from the Grantha block. The character is supposed
> to work with Tamil text and is listed in the ScriptExtensions.txt of the
> UCD. My assumption is that this information hasn't got into libo. Sorry, no
> time today to dig into that. Firefox does support ScriptExtensions correctly
> in its segmenting.

Right, we don’t currently use ScriptExtensions property. But Graphite should be skipping script itemization now (not sure what version has it), right?
Comment 17 martin_hosken 2019-11-13 02:54:26 UTC
Seems to work for me with a recent build of the font and in libo version 6.4.0.0.alpha0+ 6311bcff7f (FWIW), also in 6.0.7.3 release. I think this is probably fixed.
Comment 18 Dieter Praas 2019-11-13 08:47:18 UTC
(In reply to martin_hosken from comment #17)
> Seems to work for me with a recent build of the font and in libo version
> 6.4.0.0.alpha0+ 6311bcff7f (FWIW), also in 6.0.7.3 release. I think this is
> probably fixed.

O. K., let's close the bug as RESOLVED WORKSFORME. Feel free to reopen it, if it happens again.