Bug 127164 - Undo list is populated wrongly with "Delete slides" actions
Summary: Undo list is populated wrongly with "Delete slides" actions
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium normal
Assignee: Jim Raykowski
URL:
Whiteboard: target:6.4.0 target:6.3.4
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks: Undo-Redo PPTX
  Show dependency treegraph
 
Reported: 2019-08-26 11:30 UTC by Eduard Ardeleanu
Modified: 2019-10-14 11:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file on which the bug has been reproduced (20.24 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-08-26 11:30 UTC, Eduard Ardeleanu
Details
Repair list before Save (109.69 KB, image/png)
2019-08-26 11:31 UTC, Eduard Ardeleanu
Details
Repair list after Save (123.15 KB, image/png)
2019-08-26 11:31 UTC, Eduard Ardeleanu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eduard Ardeleanu 2019-08-26 11:30:09 UTC
Created attachment 153657 [details]
Sample file on which the bug has been reproduced

Steps to reproduce:
1. Open any file with extension .pptx in LibreOffice

2. Insert new slide into the file

3. Check Repair dialog (Repair1.png) - Correctly displays one action to undo 

4. Save the file (Use PowerPoint 2007 - 365 Format)

5. Check Repair dialog (Repair2.png) - Wrongly populated with "Delete slides" actions


Version tested: 
Version: 6.3.0.4
Build ID: libreoffice-6.3.0.4-snap1

Notes:
 ** Bug is not reproducible using .ppt or .odp files 
 ** Bug was reproduced on LibreOffice Core master build from commit https://github.com/LibreOffice/core/commit/b6fd78a9fa4bb6e53da8b8216f00bb887e1fd917
Comment 1 Eduard Ardeleanu 2019-08-26 11:31:15 UTC
Created attachment 153658 [details]
Repair list before Save
Comment 2 Eduard Ardeleanu 2019-08-26 11:31:44 UTC
Created attachment 153659 [details]
Repair list after Save
Comment 3 Xisco Faulí 2019-10-03 12:04:32 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: c9336bfb6bbf6d73d3f23c124262ade30133448d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Xisco Faulí 2019-10-03 12:07:42 UTC
Also reproducible in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

but not in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 5 Xisco Faulí 2019-10-03 12:08:19 UTC
@Jim raykowski, I thought you might be interested in this issue...
Comment 6 Jim Raykowski 2019-10-08 07:46:19 UTC
Here is a patch that prevents the page removes that happen during pptx file save from being added to undo.

https://gerrit.libreoffice.org/#/c/80429/
Comment 7 Commit Notification 2019-10-13 06:53:38 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fae4f1506fc481b8dc2977d3bf9363dd8eaf4945

tdf#127164 Don't add SdrUndoDelPage undos during pptx save

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Jim Raykowski 2019-10-13 07:07:29 UTC
Sorry, I have been informed the patch is not going to work in certain cases. Reverting now.
Comment 9 Commit Notification 2019-10-13 08:03:50 UTC
Jim Raykowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9f5d2305437fd2bb2a6ff00247e8d4d4736f6433

Revert "tdf#127164 Don't add SdrUndoDelPage undos during pptx save"

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Mike Kaganski 2019-10-14 06:16:12 UTC
Due to my mistake in commit message, the following commit was not automatically mentioned here:

https://git.libreoffice.org/core/commit/03ec3b7dd11656c8b64a94efb172e17d97ea662e

Should be fixed in master.
Comment 11 Jim Raykowski 2019-10-14 06:46:27 UTC
I can't let Mike take credit for my mistake. I put the wrong bug reference in the commit message.

Thanks Mike for sharing your time and knowledge.
Comment 12 Xisco Faulí 2019-10-14 10:07:04 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 9b5dad13b56bdde7c40970351af3da3a2c3c9350
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Mike, Thanks for fixing this issue!
Comment 13 Commit Notification 2019-10-14 11:11:23 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/5dfaf7a608a1827d1b56ac7a7d4651f26e4754d1

tdf#127164: Disable Undo during pptx save

It will be available in 6.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.