Bug Hunting Session
Bug 127208 - tilde displays like macron
Summary: tilde displays like macron
Status: UNCONFIRMED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2019-08-28 22:53 UTC by Miguel Frasson
Modified: 2019-09-05 14:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file inplementing font tests. (14.07 KB, application/vnd.oasis.opendocument.text)
2019-08-28 23:01 UTC, Miguel Frasson
Details
Screenshot of test file (142.96 KB, image/png)
2019-08-28 23:11 UTC, Miguel Frasson
Details
Screenshot of testcase on latest LO (162.30 KB, image/png)
2019-09-05 14:01 UTC, Miguel Frasson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Frasson 2019-08-28 22:53:40 UTC
Description:
Tilde accents displays sometimes displays like a macron diacritic sign. 

I realized that many times ã (a tilde) and õ (o tilde) display wrong when I am editing regular documents, for font sizes 12pt and smaller, both regular, italic, bold, bold+italic.

There is no apparent reason that triggers the bug.  


I reproduce this bug in other software, like GNU Emacs, so this may be a bug not on libreoffice, but in a font rendering, but I have no knowledge to forward to correct place.  I don't knot what is the font rendering library used.

Steps to Reproduce:
1. Set font to DejaVu Sans Mono (but it is reproducible with other fonts)

2. Copy/paste the following text on Writer

     13	12	11	10.5	10
reg	ãõ	ãõ	ãõ	ãõ	ãõ
it	ãõ	ãõ	ãõ	ãõ	ãõ
b	ãõ	ãõ	ãõ	ãõ	ãõ
b+it	ãõ	ãõ	ãõ	ãõ	ãõ

Set font according to "table" (columns are font sizes, lines are font specs regular, italic, bold, bold+italic) to each group of 2 letters.

3. Ensure magnification 100%.


Actual Results:
For DejaVu Sans Mono, observe that tildes become macrons exactly for
õ r11 i11
ã b12
ãõ bi12 bi11 bi10

Selecting all and changing font change bug reproducion. for example, Liberation Sans change bug to all letters 10pt. 

Expected Results:
Expected that all tilde accents display correctly.


Reproducible: Always


User Profile Reset: No



Additional Info:
$ uname -a
Linux sme-9373 4.15.0-58-generic #64-Ubuntu SMP Tue Aug 6 11:12:41 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

I use Xubuntu

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.3 LTS
Release:	18.04
Codename:	bionic
 

Libreoffice installed from ubuntu repositories.

$ apt list -a libreoffice
Listing... Pronto
libreoffice/bionic-updates,bionic-security,now 1:6.0.7-0ubuntu0.18.04.9 amd64 [installed]
libreoffice/bionic 1:6.0.3-0ubuntu1 amd64

From Libreoffice About dialogue:

Versão: 6.0.7.3
ID de compilação: 1:6.0.7-0ubuntu0.18.04.9
Threads da CPU:4; SO:Linux 4.15; Realizador da interface: padrão; VCL: gtk3; 
Local: pt-BR (pt_BR.UTF-8); Calc: group
Comment 1 Miguel Frasson 2019-08-28 23:01:52 UTC
Created attachment 153724 [details]
ODT file inplementing font tests.
Comment 2 Miguel Frasson 2019-08-28 23:11:11 UTC
Created attachment 153725 [details]
Screenshot of test file
Comment 3 Dieter Praas 2019-09-04 07:35:17 UTC
(In reply to Miguel Frasson from comment #1)
> Created attachment 153724 [details]
> ODT file inplementing font tests.

I can't sonfirm this with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 01837a85004a6f891a09c0a63ed7eff75d634827
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_00:07:05
Locale: en-GB (de_DE); UI-Language: en-US
Calc: threaded

It seems you're using an old version of LibreOffice. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 4 Miguel Frasson 2019-09-05 14:00:45 UTC
The problem persists exactly as before in latest version.  I tested the same odt file from attachment 1.

I guess that the problem is linux specific, on screen font rendering.

Updated my LO to latest as requested.

Version: 6.3.1.2
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: pt-BR (pt_BR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Miguel Frasson 2019-09-05 14:01:38 UTC
Created attachment 153923 [details]
Screenshot of testcase on latest LO