Bug Hunting Session
Bug 127220 - Please Provide Better Defaults for Placing Pictures in LO Writer
Summary: Please Provide Better Defaults for Placing Pictures in LO Writer
Status: RESOLVED DUPLICATE of bug 87720
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2019-08-29 14:44 UTC by Adalbert Hanßen
Modified: 2019-08-30 07:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adalbert Hanßen 2019-08-29 14:44:41 UTC
This report pertains to LibreOfficeWriter
Version: 6.4.0.0.alpha0+
Build ID: 2bed8af91fc2654b9ed2432f969d32d5741a529b
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-08-21_09:30:10
Locale: de-DE (de_DE.UTF-8); UI-Language: en-US
Calc: threaded

When placing pictures into a LO Writer document I often have to tune the picture hand. That would not be necessary if defaults from the stylesheet would be applied automatically.

I would like to be able to define that each picture placed into a document would be automatically

* anchored to paragraph (only for very small pictures, e.g. smaller than 200*35 pixels, a default anchoring as character is meaningful when writing instruction manuals related to software or similar work),
* without wrapping,
* centred horizontally, aligned to the paragraph text area, vertically to the beginning of the paragraph's
* I would prefer it if a preset distance to the text above would also be observed, e.g. 2mm to each side.

All these settings should be configurable through the properties Styles>Frame Styles>Graphics. Apparently not all settings set there automatically apply to new pictures placed into the current document with such a style sheet.

Steps to reproduce: 
1. define the preferences according to my settings (unfortunately I found no item for anchoring to the paragraph).
2. make some screenshot of moderate size.
3. place it three times to a the document with the styles defined in step 1.

Result: The screenshot is placed thee times by side, the spacing margins are observed. The pictures are pasted anchored to character. I expect them below each other by default, since Wrapping is off according to my definition in the stylesheet!

Further I would prefer it if in the properties dialogue for a graphic object in the tab Type the check mark for Keep ratio would be initially checked (currently it is off by default. I have heard that this is hard coded. Presetting it on that would require minimum effort then).

LibreOffice seems to suffer from the same syndrome as Microsoft word: Sometimes pictures inserted (e.g. pasted) into free text rather than into a table go “anywhere but not where you want them”. So I often place a table first if I want to to really control the placement of a picture, especially in large documents (where the random placement sometimes gets a nightmare). It would be advisable to automatically place a 1*1 table first if the cursor position is in free text and not in a table and then place the picture into that automatically placed 1*1 table. If it could be handled like this, I would prefer if the border grid for such an automatically placed table is automatically switched off.

By the way: Are there defined keystrokes to add a column before or after the current cell if a table or by adding a line above or below the current line. That would also be very useful for scientific work and for the placement of pictures to a document.
Comment 1 Heiko Tietze 2019-08-30 07:12:52 UTC
We discussed this topic recently (https://wiki.documentfoundation.org/Design/Meetings/2019-05-15) and had a quick poll on Twitter, see bug 45778 comment 13 and also bug 87720 (making this a dup). In a nutshell: users are split on how images are handled and the best way is to have an option. (Keeping the last used option, bug 109265 could also be valid for dropdowns, is a bit tricky as many players are in the game, ie. anchoring, wrapping, and alignment.)

*** This bug has been marked as a duplicate of bug 87720 ***