Download it now!
Bug 127254 - The number of a footnote cannot be a footnote anchor
Summary: The number of a footnote cannot be a footnote anchor
Status: RESOLVED DUPLICATE of bug 123027
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Footnote-Endnote-Properties
  Show dependency treegraph
 
Reported: 2019-08-31 14:38 UTC by Kiss Gábor
Modified: 2019-09-03 17:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the wrong, full size footnote (31.62 KB, image/jpeg)
2019-08-31 14:38 UTC, Kiss Gábor
Details
the superscript footnote number (5.43 KB, image/png)
2019-08-31 14:39 UTC, Kiss Gábor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kiss Gábor 2019-08-31 14:38:49 UTC
Created attachment 153782 [details]
the wrong, full size footnote

In the footnote area should be two possibilities for the numbers of footnotes. The default is a normal size footnote number character. Theoretically, it can be changed int he menu -> Tools -> Footnotes and Endnotes. Here in the "Footnote area" you can change the option Footnote Characters to Footnote Anchor. In this case, the number will be a superscript instead of a normal one. This is really essential because most of the time the footnotes are used in this way. It works well with LibreOffice 6.0.7.3 but I have LO 6.2.6.2 on Xubuntu and LO 6.3.0.4 on Windows 10 and neither of them works properly. I make the necessary changing in the menu but nothing happens after clicking OK.
Comment 1 Kiss Gábor 2019-08-31 14:39:47 UTC
Created attachment 153783 [details]
the superscript footnote number
Comment 2 Mike Kaganski 2019-08-31 22:22:50 UTC
"Footnote Anchor" and "Footnote Characters" are two *character styles* that define the appearance of the relevant symbols. In fact, it is *not* expected that you would need that dialog to modify what you need; instead, it is expected that you open Styles (F11), go to Character styles ("A" button there), right-click "Footnote Characters" and choose "Modify...", and make necessary adjustments (e.g., on the Position tab - set Superscript).

I don't know why it was disabled to select the same character style for both numbers in anchors and footnote area; so I don't resolve this yet (that might be intentional, or a bug). But you still can define your own character style for that, or use any other style from the list. Remember, the predefined styles are not set in stone, they are for you to begin with and fine-tune to your liking.
Comment 3 Mike Kaganski 2019-08-31 22:54:39 UTC
That was changed in https://git.libreoffice.org/core/+/e9bf0102783e23cf8b7c609a9a5265ab436dc90e

Still not clear if this is a bug (and a regression) or an intended change.
Comment 4 Dieter 2019-09-03 17:38:12 UTC

*** This bug has been marked as a duplicate of bug 123027 ***