Bug Hunting Session
Bug 127306 - CRASH: Closing LibreOffice after deleting a chart
Summary: CRASH: Closing LibreOffice after deleting a chart
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.2 rc
Hardware: All All
: highest critical
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: bibisected, bisected, haveBacktrace, regression
: 127413 127890 128397 128764 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-09-03 07:19 UTC by Xisco Faulí
Modified: 2019-11-13 20:26 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
bt Windows (windbg) (88.84 KB, text/plain)
2019-09-03 14:51 UTC, Julien Nabet
Details
gdb bt (8.80 KB, text/plain)
2019-09-05 17:12 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-09-03 07:19:35 UTC
Steps to reproduce:
1. Open Writer
2. Insert - Chart
3. Click on one of the bars ( e.g. orange ) and delete it
4. Click somewhere else in the document and remove the chart
5. Close LibreOffice

-> Crash

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: 2b4efc32e822bf41c4b729137718f3c70f692a89
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-09-03 07:20:53 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b58aa94f1f365c746135470bceb97cc182c289bc

author	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-07-16 17:41:48 +0200
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-07-18 10:27:25 +0200
commit	b58aa94f1f365c746135470bceb97cc182c289bc (patch)
tree	2f4b915889695ac214988d66312498864ead62ed
parent	2b4efc32e822bf41c4b729137718f3c70f692a89 (diff)
tdf#126424 Don't dispose decks before saving their state

Bisected with: bibisect-linux64-6.4

Adding Cc: to Samuel Mehrbrodt
Comment 2 Julien Nabet 2019-09-03 14:51:30 UTC
Created attachment 153843 [details]
bt Windows (windbg)

On Win10 with master sources updated today, I could reproduce the crash.
Comment 3 Julien Nabet 2019-09-05 17:12:29 UTC
Created attachment 153931 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I could also reproduce the crash.
Comment 4 Xisco Faulí 2019-09-23 11:00:37 UTC
*** Bug 127413 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2019-10-01 07:48:02 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e6e14b2cafd24179f8675350749878da77a31443

tdf#127306 Fix crash when closing LO after deleting a chart

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-10-01 13:11:04 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/5e0ce7dc9ebe1a8b5bd70c91bcd16a49ec487b49

tdf#127306 Fix crash when closing LO after deleting a chart

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-10-02 09:55:34 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 2215be5268a646d3cc7d138a0184c6826585b7fb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Samuel, thanks for fixing this issue!!
Comment 8 Xisco Faulí 2019-10-03 13:33:24 UTC
*** Bug 127890 has been marked as a duplicate of this bug. ***
Comment 9 Oliver Brinzing 2019-10-26 13:17:20 UTC
*** Bug 128397 has been marked as a duplicate of this bug. ***
Comment 10 Oliver Brinzing 2019-11-13 20:26:26 UTC
*** Bug 128764 has been marked as a duplicate of this bug. ***