Download it now!
Bug 127447 - FILEOPEN DOC: incorrect position of grouped drawing objects
Summary: FILEOPEN DOC: incorrect position of grouped drawing objects
Status: RESOLVED DUPLICATE of bug 121649
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-09-09 06:56 UTC by LE GARREC Vincent
Modified: 2019-10-07 10:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
WrongPositionInsideOfGroupedObjects.doc (49.00 KB, application/msword)
2019-09-09 06:56 UTC, LE GARREC Vincent
Details
LibreOfficeWrongRending.png (13.68 KB, image/png)
2019-09-09 06:57 UTC, LE GARREC Vincent
Details
MicrosoftOfficeRightRending.png (18.54 KB, image/png)
2019-09-09 06:58 UTC, LE GARREC Vincent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LE GARREC Vincent 2019-09-09 06:56:49 UTC
Created attachment 154040 [details]
WrongPositionInsideOfGroupedObjects.doc

Maybe related with #105693 ?

I have DOC file with grouped objects.

This image is right in Microsoft Office but some objects are misplaced (and maybe missing) with Libreoffice.

Please find enclosed the document with an example.

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-01_22:04:10
Locale: fr-FR (fr_FR); UI-Language: en-US
Calc: CL
Comment 1 LE GARREC Vincent 2019-09-09 06:57:37 UTC
Created attachment 154041 [details]
LibreOfficeWrongRending.png

Current result with Libreoffice
Comment 2 LE GARREC Vincent 2019-09-09 06:58:09 UTC
Created attachment 154042 [details]
MicrosoftOfficeRightRending.png

Expected result with Microsoft Office.
Comment 3 MM 2019-09-09 20:52:00 UTC
Confirmed on ubuntu 16.04 x64 with Version: 6.2.0.0.alpha1+
Build ID: 726c18db3215ec74135f51365322a6b531f328af
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-03_19:38:55
Locale: en-US (en_US.UTF-8); Calc: threaded

Unconfirmed on ubuntu 16.04 x64 with Version: 6.1.0.0.alpha1+
Build ID: 47dc3115f12ff16dc326b6edd12c46e6a6ef1843
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-05-17_00:32:17
Locale: en-US (en_US.UTF-8); Calc: group

First problem is that the left image disappears in v6.2, but not v6.1 and earlier.
Second problem is the position. That's wrong on all previous versions (were the image is correctly shown).
Comment 4 LE GARREC Vincent 2019-09-12 05:05:52 UTC
I made a bibisect.

source sha:52bbb04f1e39b2d778275c91f77b6c0714ecd0d0

tdf#120728 support SvxShape for SdrShape if not inserted
Added a fallback to allow correct SvxShape construction
when SdrObject is not yet inserted - or has no SdrPage yet.
This is needed ue to the paradigm change that a SdrObject
only has a SdrPage when it is inserted.
For more info and a discussion, see added comments.

Change-Id: I2c1a4b1bbb531501ee73ab1c98c13321c5c0b050
Reviewed-on: https://gerrit.libreoffice.org/62710
Tested-by: Jenkins
Reviewed-by: Armin Le Grand <Armin.Le.Grand@cib.de>

This is only for the missing object. The problem about wrong position happens every time.
Comment 5 Xisco Faulí 2019-10-07 10:35:59 UTC
This is a duplicate of bug 121649

*** This bug has been marked as a duplicate of bug 121649 ***