Bug 127448 - EDITING Chart axis labels become distorted, first and last tickmarks become too long
Summary: EDITING Chart axis labels become distorted, first and last tickmarks become t...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords:
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2019-09-09 07:27 UTC by NISZ LibreOffice Team
Modified: 2019-09-18 08:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the problem in Writer. (105.53 KB, image/png)
2019-09-09 07:29 UTC, NISZ LibreOffice Team
Details
Example file from Writer. (12.19 KB, application/vnd.oasis.opendocument.text)
2019-09-09 07:30 UTC, NISZ LibreOffice Team
Details
bigger shrink is a regression (28.71 KB, image/png)
2019-09-09 08:49 UTC, László Németh
Details
test file of the previous screenshots (13.67 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-09-09 08:53 UTC, László Németh
Details
Fixed distortion (13.02 KB, image/png)
2019-09-09 09:05 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-09-09 07:27:26 UTC
Description:
Chart axis labels with three categories become distorted, and has too long first and last tickmarks if the chart is shrinked in LibreOffice Writer 6.4.

Steps to Reproduce:
    1. Create a new document with LibreOffice Writer 6.4
    2. Insert a chart.
    3. Modify Data table.
    4. Insert 2 new Categories.
    5. Fill the empty cells.
    6. Shrink the chart horizontally and vertically.
    7. Save the file. Open a copy with LibreOffice 5.3.
    8. View the attached screenshot.
    9. Notice that chart axis labels become distorted, and the first and last tickmarks are too long.

Actual Results:
Chart axis labels are distorted, first and last tickmarks are too long.

Expected Results:
Chart axis labels should not be distorted, size of tickmarks should not change.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Verzió: 6.4.0.0.alpha0+ (x64)
Build az.: 265552e8ab1ba86f09146470156ee32db269197b
CPU szálak: 8; OS: Windows 10.0; Felületmegjelenítés: GL; VCL: win; 
Területi beállítások: hu-HU (hu_HU); UI-Language: hu-HU
Calc: CL

Verzió: 5.3.0.3
Build az.: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU szálak: 4; Rendszer verziója: Windows 6.2; Felületmegjelenítés: GL; Elrendezésmotor:új; 
Területi beállítások: hu-HU (hu_HU); Calc: CL

also bad in: Verzió: 5.0.0.5
Build az.: 1b1a90865e348b492231e1c451437d7a15bb262b
Területi beállítások: hu-HU (hu_HU)
Comment 1 NISZ LibreOffice Team 2019-09-09 07:29:02 UTC
Created attachment 154043 [details]
Screenshot of the problem in Writer.
Comment 2 NISZ LibreOffice Team 2019-09-09 07:30:43 UTC
Created attachment 154044 [details]
Example file from Writer.
Comment 3 Balázs Varga 2019-09-09 07:49:25 UTC
Confirmed in all versions mentioned above.
Comment 4 László Németh 2019-09-09 08:49:21 UTC
Created attachment 154047 [details]
bigger shrink is a regression
Comment 5 László Németh 2019-09-09 08:51:36 UTC
It seems, bigger distortion of the chart in 6.3/master is a regression, caused by changing of the rotation, see the attached screenshot and document in LO 6.0 and master.
Comment 6 László Németh 2019-09-09 08:53:25 UTC
Created attachment 154048 [details]
test file of the previous screenshots
Comment 7 László Németh 2019-09-09 09:05:24 UTC
Created attachment 154049 [details]
Fixed distortion
Comment 8 Commit Notification 2019-09-09 09:19:45 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/55136439e71b7adc62a46a3d3dc8de26d54d989d%5E%21

tdf127448 Chart: Avoid distortion of charts with multilevel axis labels

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-09-16 07:25:34 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/996d41f2fe6a9eaced42269d5eee9bcd8110dca3%5E%21

tdf#127448 Chart: Avoid distortion of charts with multilevel axis labels

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-09-18 07:16:24 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e9024b469530a483a1019ccef2b8b664c1696456

tdf#127448 fix unit test for HiDPI displays

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-09-18 08:37:26 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/66148574e29d9e5509bdb408b06bb53d80ba0641

tdf#127448 fix unit test for HiDPI displays

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.