Bug Hunting Session
Bug 127450 - Impress crashes by changing the symbol of a bulleted list (GTK crash with 3.18, no crash 3.22)
Summary: Impress crashes by changing the symbol of a bulleted list (GTK crash with 3.1...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2019-09-09 09:28 UTC by mbb
Modified: 2019-10-28 14:35 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screencast (1.13 MB, video/webm)
2019-09-11 12:26 UTC, Timur
Details
console logs (41.48 KB, text/plain)
2019-09-11 19:32 UTC, Julien Nabet
Details
Trace log from crash reproduction while changing a symbol character size (10.82 KB, text/plain)
2019-09-12 13:13 UTC, mbb
Details
Trace log Mint 18.3 GTK 3.18 LO 6.4+ (145.25 KB, text/plain)
2019-09-12 14:27 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mbb 2019-09-09 09:28:01 UTC
Description:
I created a numbered list, then duplicated the slide and on the new copy I changed the first numbered item to a bulleted square symbol. The square symbol had 100% character size and I want it to have 45%. Every time I try to change the character size of the square symbol Impress crashes. In fact this happens every time I try to change the character size of any symbol from a bulleted list.

Steps to Reproduce:
1. Create a bulleted list.
2. Change the character size of the symbol from any item on the list created.

Actual Results:
Crash with recovery dialog.

Expected Results:
Change the character size of the symbol of the selected item from the bulleted list


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 Timur 2019-09-09 10:40:34 UTC
I reproduced this as reported, both with starting bullet list or numbered list.
Only in Linux. Tested with master 6.4+. I'll mark Regression.

In crash report, I don't see a link in my Mint. 
@mbb: if you see the link, please write it here, so that we fill "Crash report or crash signature:" field.
Comment 2 Julien Nabet 2019-09-09 12:31:11 UTC
On Win10 with master sources updated today, I can't select a symbol of a bullet list, I just can select what I typed after each bullet/square, etc.

I suppose I must have missed something but I don't know what.
Comment 3 Xisco Faulí 2019-09-10 00:04:32 UTC
Hi Timur,
Which are the steps to reproduce it ?

I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: f4f8bccbd4e2c3979a83d5b2f49e16a99a3a2016
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Timur 2019-09-10 08:27:53 UTC
Steps that crash for me with 6.4+:
1. open Impress new presentation
2. set cursor in to add text
3. Use sidebar to turn on numbering
4. write some text like L1, enter, L2, enter, L3
5. select text from first point (here: L1)
6. go to Format - Bullets and numbering
7. crash

OR

1. open Impress new presentation
2. set cursor in to add text
3. Use sidebar to turn on bullets
4. write some text like L1, enter, L2
5. select text from first point (here: L1)
6. go to Format - Bullets and numbering to change bullet type
7. crash

Why I don't see a crash report link in my Linux Mint?
Comment 5 Timur 2019-09-10 08:29:44 UTC
(In reply to Julien Nabet from comment #2)
> On Win10 with master sources updated today..

(In reply to Timur from comment #1)
> Only in Linux. Tested with master 6.4+.
Comment 6 Xisco Faulí 2019-09-10 09:53:03 UTC
(In reply to Timur from comment #4)
> Why I don't see a crash report link in my Linux Mint?

Indeed, it doesn't crash here:

Version: 6.4.0.0.alpha0+
Build ID: f4f8bccbd4e2c3979a83d5b2f49e16a99a3a2016
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Timur 2019-09-11 12:26:54 UTC
Created attachment 154101 [details]
Screencast

Please see the crash and that I don't see crash report link.
Comment 8 Xisco Faulí 2019-09-11 13:18:13 UTC Comment hidden (obsolete)
Comment 9 Timur 2019-09-11 13:45:39 UTC Comment hidden (obsolete)
Comment 10 Xisco Faulí 2019-09-11 14:40:20 UTC
@Timur, I'm asking for the GTK version -> https://stackoverflow.com/questions/126141/how-do-you-find-out-which-version-of-gtk-is-installed-on-ubuntu
Comment 11 Timur 2019-09-11 14:48:35 UTC
$ dpkg -s libgtk-3-0|grep '^Version'
Version: 3.18.9-1ubuntu3.3
Comment 12 Xisco Faulí 2019-09-11 15:03:41 UTC
(In reply to Timur from comment #11)
> $ dpkg -s libgtk-3-0|grep '^Version'
> Version: 3.18.9-1ubuntu3.3

@Caolán, Do you have the chance to check this issue with GTK 3.18 ? It doesn't crash with 3.22
Comment 13 Julien Nabet 2019-09-11 19:32:30 UTC
Created attachment 154113 [details]
console logs

On pc Debian x86-64 with master sources updated today + gtk3 I don't reproduce this but noticed a lot of warnings/errors in console.
Perhaps it may give some hints.
Comment 14 Timur 2019-09-12 07:38:28 UTC
Also doesn't crash for me with GTK version: 3.22.30-1ubuntu4.

Here are some console messages from the crashing version:

warn:legacy.tools:4095:4095:editeng/source/editeng/editeng.cxx:1960: GetDocPosTopLeft: Doc not formatted - unable to format!
warn:legacy.tools:4095:4095:editeng/source/editeng/editeng.cxx:1923: GetFirstLineStartX: Doc not formatted - unable to format!
warn:legacy.osl:4095:4095:editeng/source/editeng/impedit2.cxx:4211: GetEditCursor: Not formatted
warn:legacy.tools:4095:4095:editeng/source/editeng/impedit.cxx:290: Portion in Selection not formatted!
soffice.bin: /tinderbox/buildslave/source/libo-master/vcl/unx/gtk3/gtk3gtkinst.cxx:10823: GtkInstanceBuilder::GtkInstanceBuilder(GtkWidget*, const rtl::OUString&, const rtl::OUString&): Assertion `rc && "could not load UI file"' failed.
warn:desktop:4095:4095:desktop/source/app/sofficemain.cxx:88: minidump generated: /home/t/Downloads/LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64_archive/program/../program/../libreofficedev/4/crash//73171823-7b85-6c1c-6e8eeddf-577cc9f6.dmp
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
warn:xmloff:4095:4095:xmloff/source/style/impastpl.cxx:397: Adding duplicate family graphic with mismatching mapper ! P25SvXMLExportPropertyMapper 28XMLShapeExportPropertyMapper
warn:xmloff:4095:4095:xmloff/source/style/impastpl.cxx:397: Adding duplicate family presentation with mismatching mapper ! P25SvXMLExportPropertyMapper 28XMLShapeExportPropertyMapper
warn:editeng:4095:4095:editeng/source/uno/unofield.cxx:404: Id service unknown: 11
warn:vcl.opengl:4154:4154:vcl/opengl/x11/X11DeviceInfo.cxx:356: unknown vendor => blocked
Comment 15 Julien Nabet 2019-09-12 07:55:03 UTC
Just for information, according to https://en.wikipedia.org/wiki/GTK#Linux/Unix
3.18 has been released at 2015/09/24
3.20 2016/03/21
3.22 2016/09/21

Also Linux Mint 19 includes gtk lib 3.22 version according to https://forums.linuxmint.com/viewtopic.php?t=270976
Comment 16 mbb 2019-09-12 11:19:40 UTC
I'm sorry for the delay.

In reply to Comment #1:
> In crash report, I don't see a link in my Mint. 

I don't see a link either, and the crash report doesn't appear as it does on the screencast attached by you. After the crash notice, LO restarts and goes directly to the recovery dialog.

Some more info:

- there's no output from console whatsoever
- Versão: 6.2.6.2
- ID da versão: 6.2.6-2
- Processos do CPU: 4
- SO: Linux 4.14
- Gestão da interface: GL
- VCL: kde5
- Configuração regional: pt-PT (pt_PT.UTF-8)
- Idioma da interface: pt-PT
- Calc: threaded
- gtk2 2.24.32-1
- gtk3 1:3.24.10-1
Comment 17 Timur 2019-09-12 12:06:28 UTC
(In reply to Julien Nabet from comment #15)
> Also Linux Mint 19 includes gtk lib 3.22 version according to
> https://forums.linuxmint.com/viewtopic.php?t=270976
Right, that one doesn't crash with 6.4+. But 18.3 does with GTK 3.18.

Interesting that in my GTK 3.18 case, LO 6.2.6 doesn't crash, just 6.4+.
Comment 18 Julien Nabet 2019-09-12 12:20:41 UTC
(In reply to Timur from comment #17)
> ...
> Interesting that in my GTK 3.18 case, LO 6.2.6 doesn't crash, just 6.4+.

Noticing https://developer.gnome.org/gtk3/stable/GtkBuilder.html#gtk-builder-add-from-file, perhaps some new instruction (I mean not know by GTK 3.18) in the ui file
But since it crashed when you tried to open bullets and numbering, it makes me think about https://opengrok.libreoffice.org/xref/core/sd/uiconfig/sdraw/ui/bulletsandnumbering.ui?r=ed0c1bc4
Taking a look at its git history, I don't see what could be the pb (but am not gtk expert)

Would it be possible you attach a backtrace + all console logs? (seehttps://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)(In reply to Timur from comment #17)
Perhaps it may give some hints
Comment 19 Xisco Faulí 2019-09-12 13:05:44 UTC
Can anyone with GTK3.18 test this

--- a/cui/uiconfig/ui/bulletandposition.ui
+++ b/cui/uiconfig/ui/bulletandposition.ui
@@ -1001,6 +1001,8 @@
                         <property name="shadow_type">in</property>
                         <property name="max_content_width">150</property>
                         <property name="max_content_height">300</property>
+                        <property name="hscrollbar_policy">never</property>
+                        <property name="vscrollbar_policy">never</property>
                         <child>
                           <object class="GtkViewport">
                             <property name="visible">True</property>


We have a similar fix here -> https://cgit.freedesktop.org/libreoffice/core/commit/?id=3d70b1253f964fb75cd4b5915b8dd031ee54d5c7
Comment 20 mbb 2019-09-12 13:13:55 UTC
Created attachment 154136 [details]
Trace log from crash reproduction while changing a symbol character size
Comment 21 Timur 2019-09-12 14:27:23 UTC
Created attachment 154137 [details]
Trace log Mint 18.3 GTK 3.18 LO 6.4+
Comment 22 Julien Nabet 2019-09-12 14:58:35 UTC
I think Xisco may be right about the ui file.

Taking a look at the bt, we can go until cui/uiconfig/ui/bulletandposition.ui

Indeed there's "SdAbstractDialogFactory_Impl::CreateSvxBulletAndPositionDlg"
which gives:
VclPtr<AbstractSvxBulletAndPositionDlg_Impl>::Create(std::make_unique<SvxBulletAndPositionDlg>(pParent, *pAttr, pView))

then:
118      : GenericDialogController(pWindow, "cui/ui/bulletandposition.ui", "BulletAndPosition")
(see https://opengrok.libreoffice.org/xref/core/sd/source/ui/dlg/BulletAndPositionDlg.cxx?r=ff6e8c73#118)
Comment 23 Caolán McNamara 2019-09-13 21:18:24 UTC
Maybe this is a regression since bug 126070
Comment 24 Aron Budea 2019-09-16 15:51:10 UTC
I don't think the issue under investigation is the original one, since the identified commit below isn't in 6.2. Nevertheless, there's a crash with gtk 3.18, so it's an issue nonetheless.

(In reply to Caolán McNamara from comment #23)
> Maybe this is a regression since bug 126070

Indeed, the crash from comment 4 (or even simpler, just open Format -> Bullets and Numbering...) could be bibisected to the following commit using repo bibisect-linux-64-6.4 in Ubuntu 16.04.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9a516a4b229f9a52c9c1f05d247cebddb1ba5c17
author		Gülşah Köse <gulsah.kose@collabora.com>	2019-07-19 16:22:00 +0300
committer	Gülşah Köse <gulsah.kose@collabora.com>	2019-07-24 13:00:20 +0200

"tdf#126070 Show scroll bars when preview overflows."

I also checked the change suggested in comment 19 directly applied to share/config/soffice.cfg/cui/ui/bulletandposition.ui (is that supposed to work?) in the bibisect build, but the crash did not go away.
Comment 25 Xisco Faulí 2019-09-16 18:45:30 UTC
(In reply to Aron Budea from comment #24)
> I don't think the issue under investigation is the original one, since the
> identified commit below isn't in 6.2. Nevertheless, there's a crash with gtk
> 3.18, so it's an issue nonetheless.
> 
> (In reply to Caolán McNamara from comment #23)
> > Maybe this is a regression since bug 126070
> 
> Indeed, the crash from comment 4 (or even simpler, just open Format ->
> Bullets and Numbering...) could be bibisected to the following commit using
> repo bibisect-linux-64-6.4 in Ubuntu 16.04.
> 
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=9a516a4b229f9a52c9c1f05d247cebddb1ba5c17
> author		Gülşah Köse <gulsah.kose@collabora.com>	2019-07-19 16:22:00 +0300
> committer	Gülşah Köse <gulsah.kose@collabora.com>	2019-07-24 13:00:20 +0200
> 
> "tdf#126070 Show scroll bars when preview overflows."
> 
> I also checked the change suggested in comment 19 directly applied to
> share/config/soffice.cfg/cui/ui/bulletandposition.ui (is that supposed to
> work?) in the bibisect build, but the crash did not go away.

Hi Aron,
Thanks for the bisection.
And what about reintroduced

<property name="hscrollbar_policy">never</property>
<property name="vscrollbar_policy">never</property>

in cui/uiconfig/ui/bulletandposition.ui deleted in https://cgit.freedesktop.org/libreoffice/core/commit/?id=9a516a4b229f9a52c9c1f05d247cebddb1ba5c17 ??
Comment 26 Aron Budea 2019-09-16 20:25:48 UTC
(In reply to Xisco Faulí from comment #25)
> And what about reintroduced
> 
> <property name="hscrollbar_policy">never</property>
> <property name="vscrollbar_policy">never</property>
> 
> in cui/uiconfig/ui/bulletandposition.ui deleted in
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=9a516a4b229f9a52c9c1f05d247cebddb1ba5c17 ??
Hi Xisco, I believe I addressed that in my last paragraph in comment 24, is there anything else?
Comment 27 Timur 2019-09-17 08:14:06 UTC
(In reply to Aron Budea from comment #24)
> I don't think the issue under investigation is the original one, since the
> identified commit below isn't in 6.2. Nevertheless, there's a crash with gtk
> 3.18, so it's an issue nonetheless.
Right. It's me who hijacked bug report because I couldn't repro that one. But we will also not forget the original one. Thank you.
Comment 28 Caolán McNamara 2019-09-30 15:55:02 UTC
Its max_content_width/max_content_height which doesn't exist as a property in 3.18, though glade doesn't warn about it.

(the version listed that this crashes in can't be right btw)
Comment 29 Commit Notification 2019-09-30 18:31:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6533c390838b9635da351e40498cde73034fffbd

Resolves: tdf#127450 max_content_[width|height] isn't available in gtk 3.18

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Caolán McNamara 2019-10-01 07:54:53 UTC
fixed in master, backport to 6-3 in gerrit
Comment 31 Commit Notification 2019-10-01 09:32:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/259ea5539e54bedc7786763841f2bee44dc32e7e

Resolves: tdf#127450 max_content_[width|height] isn't available in gtk 3.18

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Xisco Faulí 2019-10-01 09:33:04 UTC
Dear mbb, Timur,
Could you please verify the issue is fixed in a master build from http://dev-builds.libreoffice.org/daily/master/ ?
Comment 33 Timur 2019-10-01 10:35:57 UTC Comment hidden (obsolete)
Comment 34 Timur 2019-10-15 09:31:33 UTC
Tested with https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/current/master_dbg~2019-10-14_16.39.37_LibreOfficeDev_6.4.0.0.alpha0_Linux_x86-64_archive.tar.gz.

No repro in Mint 18.3. I set Verified.

mbb, please also test (just run ./soffice in extracted's subfolder "program").
Comment 35 mbb 2019-10-28 14:35:58 UTC
(In reply to Timur from comment #34)
> Tested with
> https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-
> dbg/current/master_dbg~2019-10-14_16.39.37_LibreOfficeDev_6.4.0.0.
> alpha0_Linux_x86-64_archive.tar.gz.
> 
> No repro in Mint 18.3. I set Verified.
> 
> mbb, please also test (just run ./soffice in extracted's subfolder
> "program").

I confirm. The problem is solved.

Sorry for the delay, once again, and thank you all.