Download it now!
Bug 127497 - Navigator Allow sorting of headers within a chapter
Summary: Navigator Allow sorting of headers within a chapter
Status: RESOLVED DUPLICATE of bug 38093
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: VistaMail1
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-11 13:20 UTC by VistaMail1
Modified: 2019-09-11 19:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
navigator: allow sorting of headers and text (37.58 KB, image/png)
2019-09-11 13:21 UTC, VistaMail1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description VistaMail1 2019-09-11 13:20:43 UTC
Description:
If I have a long list of chapters, there is a need for sorting them within their header. It would be great, if the navigator could do this for me.

I tried the workaround with "global document", but it did not really work fine.

In my example on the screenshot there is a long list of stocks. Every time I add a stock, there is the need to sort it manually in alpahbetic order. Would be great, if LibreOffice would do this for me!

Our ideas need not to stop at alphabetical sort. There can saved a lot of work, if it would be possible just to write figures into a text, mark them as headers and to sort the text-parts by the navigator. It would speed up the relaunch and editing of long textes dramatically. Very often we descide to re-order the content of a document in a different way.

Steps to Reproduce:
1.create a chapter H1
2.create many, many underchapters H2 with much text and images
3.sort the H2

Actual Results:
spend an hour to sort the H2s in alphabetic order

Expected Results:
1. open the navigator
2. right click H1 and use "sort H2 alphabetically" (wish of feature!)
3. done in a second!


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 VistaMail1 2019-09-11 13:21:55 UTC
Created attachment 154103 [details]
navigator: allow sorting of headers and text
Comment 2 V Stuart Foote 2019-09-11 14:02:52 UTC

*** This bug has been marked as a duplicate of bug 38093 ***
Comment 3 VistaMail1 2019-09-11 17:25:13 UTC
I hardly can see, what those two issues shall have in common. They are not even the same software. My suggestion is for writer, the other thing for impress.

And the both do so different things, they cannot be compared.
Comment 4 V Stuart Foote 2019-09-11 19:03:19 UTC
Nope it is part and parcel, and resolving duplicate is normal QA handling.

*** This bug has been marked as a duplicate of bug 38093 ***