Bug 127560 - Crash when restart LO after having installed languagetool.oxt (gtk3)
Summary: Crash when restart LO after having installed languagetool.oxt (gtk3)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2019-09-15 17:15 UTC by Julien Nabet
Modified: 2019-09-20 06:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with debug symbols (gtk3) (33.86 KB, text/plain)
2019-09-15 17:16 UTC, Julien Nabet
Details
gdb bt (36.71 KB, text/plain)
2019-09-19 18:49 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2019-09-15 17:15:54 UTC
Description:
On pc Debian x86-64 with master sources updated today, I got a crash when I restart LO after having installed languagetool.oxt

Steps to Reproduce:
1. Retrieve LanguageTool file from https://languagetool.org/download/LanguageTool-4.6.oxt (about 121MB)
2. Launch LO (Writer for example)
3. Tools/Extension Manager...
4. Click Add button
5. Select oxt file and choose "Only for me"
6. Once finished, close Extension manager window
=> Lo propose to restart now or later
7. select "Now"


Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 Julien Nabet 2019-09-15 17:16:37 UTC
Created attachment 154178 [details]
bt with debug symbols (gtk3)
Comment 2 Julien Nabet 2019-09-15 17:36:59 UTC
I don't reproduce this with gen rendering.
Comment 3 Julien Nabet 2019-09-15 18:00:56 UTC
Not reproduced too with kf5 rendering.
Comment 4 Xisco Faulí 2019-09-17 05:26:26 UTC
I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: 0d90da9ea0a23c9c4afac62025208559b1496a0e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 5 Julien Nabet 2019-09-17 05:58:14 UTC
Here is the info:
Version: 6.4.0.0.alpha0+
Build ID: 7d41122d44f8566316d984333b17af39cf413a52
CPU threads: 12; OS: Linux 5.2; UI render: default; VCL: gtk3; 
Locale: fr-FR (fr_FR.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Timur 2019-09-18 10:34:21 UTC Comment hidden (obsolete)
Comment 7 Timur 2019-09-18 12:04:58 UTC
No crash. Linux Mint GTK3 v3.18.9 with master AppImage.
Comment 8 Julien Nabet 2019-09-18 13:10:46 UTC
(In reply to Timur from comment #6)
> (In reply to Julien Nabet from comment #2)
> > I don't reproduce this with gen rendering.
> > Not reproduced too with kf5 rendering.
> What does this mean? What rendering was produced with?

By default, I use gtk3
Comment 9 Timur 2019-09-19 08:19:37 UTC
Did you test with older versions (AppImage)? Do you have Crash Report?
Comment 10 Julien Nabet 2019-09-19 08:23:19 UTC
Nope, i just provided a bt.
Comment 11 Julien Nabet 2019-09-19 18:49:03 UTC
Created attachment 154298 [details]
gdb bt

I updated my master sources today + removed LO profile, I still reproduce this.

Perhaps there's a link with:
[Detaching after fork from child process 27749]

> accepting pipe,name=d0a7c841c5df21b6530bc3fae3b75a8119315f7b24caadcbc5535baaa3de3...connection established.[New Thread 0x7fff209b5700 (LWP 27755)]

or

warn:desktop:26949:27059:desktop/source/deployment/registry/package/dp_package.cxx:936:  com.sun.star.deployment.DeploymentException message: Could not read file file:///home/julien/lo/libreoffice/instdir/program/../program/../user/uno_packages/cache/uno_packages/lur1ofl2.tmp_/LanguageTool-4.6.oxt/description/desc_en.txt
    wrapped: com.sun.star.ucb.InteractiveAugmentedIOException message: an error occurred during file opening context: fileaccess::BaseContent Code: 22
Comment 12 Timur 2019-09-20 06:51:33 UTC
(In reply to Timur from comment #9)
> Did you test with older versions (AppImage)? Do you have Crash Report?

I meant: Can you please test with older versions to see when this starts for you?
And possibly get some Crash report, that we don't have due to bug 126488.
Comment 13 Julien Nabet 2019-09-20 06:59:19 UTC
I've already twice the sources:
one for build with enable-dbgutil for most of my tests
one for build with enable-symbols for Flamegraph.

I don't want to add another build again.

Let's close this one if I'm the only one to reproduce this.