Bug 127569 - Print preview does not show hidden text when it's set to be printed
Summary: Print preview does not show hidden text when it's set to be printed
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print-Preview
  Show dependency treegraph
 
Reported: 2019-09-16 07:38 UTC by Mike Kaganski
Modified: 2021-08-13 06:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2019-09-16 07:38:15 UTC
Print preview in Writer does not show hidden text when it's set to be printed

Steps:

1. In a new text document, add a character style named "Hidden", with '[x] Hidden' checked in Font Effects (possibly set it also to bold and/or red to easily see it when needed)
2. Type some lorem ipsum text; apply "Hidden" character style to part of it
3. In Options->LibreOffice Writer->Print, check the '[x] Hidden text' under Content group
4. Toggle Print Preview (File->Print Preview)
==> the hidden text is not shown - BAD
5. Open Print dialog (File->Print...)
==> the hidden text is visible in the preview panel (if enabled) - GOOD

Tested with Version: 6.3.1.2 (x64)
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 1 Dieter 2019-09-17 16:53:16 UTC Comment hidden (obsolete)
Comment 2 Xisco Faulí 2019-09-18 11:55:06 UTC
Also reproduced in

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 3 Dieter 2021-08-13 06:54:23 UTC
Still present in

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ac80ec817eb07c77a51bc0729985a473c734182e
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL