Download it now!
Bug 127572 - Provide a locale setting with decimal point and ISO date format
Summary: Provide a locale setting with decimal point and ISO date format
Status: CLOSED DUPLICATE of bug 46448
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-16 09:16 UTC by Robert Pollak
Modified: 2020-07-06 06:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Pollak 2019-09-16 09:16:29 UTC
Description:
To get decimal points and time in ISO 8601 format (similar to yyyy-MM-dd hh:mm:ss),
I am using the "en_DK" locale, as described e.g. http://www.ivoras.net/blog/tree/2010-12-20.the-wonderful-en_dk-locale.html or https://unix.stackexchange.com/questions/62316/why-is-there-no-euro-english-locale .
(More specifically, I have set "localectl set-locale LANG=en_DK.utf8" in my Linux Mint 19.2.)

However, this is not reflected in LibreOffice, and the en_DK locale is not even listed under Options->Language Settings->Languages->Locale setting.

So let me sincerely suggest to add a locale setting with decimal point and ISO date format in this internal locate settings list.

Steps to Reproduce:
1. set "localectl set-locale LANG=en_DK.utf8"
2. launch LO
3. notice that the dates are still formatted as MM/dd/yyyy instead of yyyy-MM-dd.
4. Try to find a locale in Options->Language Settings->Languages->Locale setting that both has decimal points and yyyy-MM-dd.


Actual Results:
I did not find such locale.

Expected Results:
I should have a way to both use decimal points and yyyy-MM-dd date format.


Reproducible: Always


User Profile Reset: No



Additional Info:
I currently see this in Version: 6.0.7.3, which is packaged in Linux Mint 19.2 (based on Ubuntu 18.04.2 LTS).
Comment 1 Julien Nabet 2019-09-16 09:33:20 UTC
Could you give a try to a recent LO version? (see https://launchpad.net/~libreoffice/+archive/ubuntu/ppa)
Comment 2 Robert Pollak 2019-09-16 11:55:15 UTC
I have now used this PPA to update to LO 6.3.1.2. I still see the problem there:
I get wrongly formatted dates (MM/dd/yy), so LANG=en_DK.utf8 is ignored.

I have tried three ways of launching Calc: via application menu, via double-clicking a spreadsheet file, and via terminal window.
Comment 3 Julien Nabet 2019-09-16 12:44:44 UTC
What locale do you use in LO?
There's perhaps no en_DK but there's a Danish locale.
About Calc and Danish, there's da_DK.xml:
https://opengrok.libreoffice.org/xref/core/i18npool/source/localedata/data/da_DK.xml?r=5932aa91
Comment 4 Robert Pollak 2019-09-18 08:12:54 UTC
"Locale setting" said "Default - {en}".

I have now installed the Danish language package libreoffice-l10n-da, then I switched the LO locale setting to "Danish". This showed me that the Danish locale in in both ways not suitable:
* It uses a comma as decimal separator.
* Its default date format is dd-MM-yy.

For the moment, I will stick with my workaround, using {en} and manually redefining the date format to yyyy-MM-dd. Unfortunately, many of the files I am processing are read-only or csv files, so I have to introduce reformatted copies.
Comment 5 Robert Pollak 2019-09-18 08:15:18 UTC
Is this da_DK.xml a file I could edit to my wishes (e.g. creating my own en_DK.xml), then use in LO?
Comment 6 Julien Nabet 2019-09-18 09:22:29 UTC
(In reply to Robert Pollak from comment #5)
> Is this da_DK.xml a file I could edit to my wishes (e.g. creating my own
> en_DK.xml), then use in LO?

I don't think so but am not an expert.

However, you've got some parameters which may perhaps help in Tools/Options/Language settings/Languages:
- Key decimal separator
- pattern dates
Comment 7 Robert Pollak 2019-09-18 11:43:50 UTC
Those are both useless, because they do not define the default format for existing floating point and time data:
- The "Decimal separator key" only configures which symbol is generated when you press the decimal separator key on your number pad.
- The "Date acceptance patterns" only define how dates can be keyed in.
(This is all described in the Help.)
Comment 8 Julien Nabet 2019-09-18 13:26:34 UTC
Thank you for your feedback. I must recognize I'm stuck, I won't be able to help here, so uncc myself.
Comment 9 Rizal Muttaqin 2020-07-04 03:56:04 UTC
(In reply to Robert Pollak from comment #5)
> Is this da_DK.xml a file I could edit to my wishes (e.g. creating my own
> en_DK.xml), then use in LO?

You can propose it if there is no any. 

cc  Eike Rathke as he has helped me in https://bugs.documentfoundation.org/show_bug.cgi?id=131297
Comment 10 Eike Rathke 2020-07-06 06:50:08 UTC
Effectively this is a duplicate, free-form default formats.

*** This bug has been marked as a duplicate of bug 46448 ***