Download it now!
Bug 127618 - can't copy a table with a row of 'numeric, 2 dec' into a new tabel in 'base'.
Summary: can't copy a table with a row of 'numeric, 2 dec' into a new tabel in 'base'.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
6.2.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-18 09:03 UTC by evertjebevertje
Modified: 2019-09-26 10:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description evertjebevertje 2019-09-18 09:03:05 UTC
Description:
can't copy a older table in to a new table. (when it has a NUMERIC,2dec row)

also copying numbers from a calc-file doesn't work. it takes the wrong numbers.
It looks of it does something with the row right next to it.
That contains 07:00 , 07,25 , 07,75 , 8 , 8,25 ...etc (its in VARCHAR)
The row that's going wrong is on the right next to it.
It contains: 7 , 7,25 , 7,5 , 7,75 , 8 , 8,25 ....etc(should be NUMERIC,2dec)
when i coppy this into the table i get
0,07 , 0,07 , 0,07 , 0,07 , 0,08 , 0,08 ...etc
when i changed NUMERIC,2dec int 3 dec:
0,007 , 0,007.... etc

Steps to Reproduce:
1. copy an older table with a NUMERIC, 2dec row.
2. paste into new table.
3.

Actual Results:
Get a error


Expected Results:
doesn't work


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: nl
Module: OfficeDatabaseDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Robert Großkopf 2019-09-18 17:09:55 UTC
Which (internal) database do you use?
Could you attach an example here?
Comment 2 evertjebevertje 2019-09-19 09:33:37 UTC
when i'm working in Libreoffice Base, and when i want to copy NUMERIC data in a table, I get the wrong result. 
An older table that worked before, i als can't add this table in. it wan't recognize the NUMERIC fields.

If i paste the NUMERIC row from a calc file into the table with empty numeric row, the numbers get mixed up with numbers from a VARCHAR row on the left.

Maybe i use the wrong word for 'row' ?

Table: arrivel
ID (integer)          
Time_in_quarters (VARCHAR)
Value_1 (numeric,2dec)

ID               = auto number
Time_in_quorters = Contains: 07:00 , 07:15 , 07:30 ,..etc
Value_1          = Contains: 7     , 7,25  , 7,5   ,..etc

Building this, u make a spreathsead, and let Librecalc do the work.
Pasting these numbers into the "table" field, used to work.

But now I get the wrong numbers in the table.

Value_1         = Contains: 0,07    ,0,07   ,0,07  ,  0,07  ,0,08 ...etc

It looks if it takes the '7' from '07:00' 

I've tride a lot of methods, but keeps the same result. It looks to me as a bug, because reacts to a difrent row.
Comment 3 evertjebevertje 2019-09-19 09:39:09 UTC
- I use Manjaro.
Comment 4 Alex Thurgood 2019-09-19 10:23:00 UTC
@evertjebevertje :

Please indicate which kind of database you are using?
You still haven't replied to Robert's question in that regard, and we need that information in order to determine whether this is a known bug, or a new problem.

Ideally, we would need a test database file with step-by-step instructions so that we could try and reproduce the issue.

Additionally, you say you are using Manjaro as the OS, but which version of LibreOffice are you using - the one provided by Manjaro packaging system (distrib provided) or a release version provided by the LibreOffice project from its download page ?

What you describe sounds like an already known bug which has recently been fixed by the LibreOffice project, in which case this report will be a duplicate. Obviously, if you are using a Manjaro provided version, then you will need to either wait until Mnajaro provides an updated version that takes into account that fix, or else download and install a daily build from the LibreOffice download page.
Comment 5 evertjebevertje 2019-09-19 10:52:56 UTC
I installed the fresh libreoffice install, and the problem is solved

Thanks.

I realy enjoy libreoffice>
Comment 6 Xisco Faulí 2019-09-26 10:08:03 UTC
(In reply to evertjebevertje from comment #5)
> I installed the fresh libreoffice install, and the problem is solved
> 
> Thanks.
> 
> I realy enjoy libreoffice>

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.