Bug 127700 - New behaviour of ALEA() and ALEA.ENTRE.BORNES(a;b)
Summary: New behaviour of ALEA() and ALEA.ENTRE.BORNES(a;b)
Status: RESOLVED DUPLICATE of bug 102257
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-22 15:59 UTC by KELLER
Modified: 2019-09-22 17:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KELLER 2019-09-22 15:59:37 UTC
Description:
The behaviour of ALEA.ENTRE.BORNES(a;b) have changed since Calc 6.2.x
I prefer the old behaviour :
F9, the result don't change
Crtl + Shift + F9, the result change

Can you create a fonction as ALEA.ENTRE.BORNES(a;b;booléen) ?
If the booléen is True, it corresponds at the old behaviour, and if it False, it corresponds at the new behaviour.


Steps to Reproduce:
1. In A1 : ALEA.ENTRE.BORNES(1;6)
2. press F9
3.

Actual Results:
New number

Expected Results:
No new number


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 m.a.riosv 2019-09-22 16:36:45 UTC

*** This bug has been marked as a duplicate of bug 102257 ***
Comment 2 koukasio 2019-09-22 17:29:13 UTC
There are going to be more users when upgrading to >6.2 to agree as to how much of an antifeature this change was for them. Speaking for myself: this is disastrous, I can't upgrade until fixed.
I have suggested in https://bugs.documentfoundation.org/show_bug.cgi?id=102257 for one or two new functions: randnv and randbetweennv (nv meaning non-volatile). This way old users can do a find-replace in their old spreadsheets and move on with their lives.
My previous comments:
https://bugs.documentfoundation.org/show_bug.cgi?id=102257#c12
https://bugs.documentfoundation.org/show_bug.cgi?id=102257#c13