Download it now!
Bug 127717 - PDF Form export does not embed input field fonts
Summary: PDF Form export does not embed input field fonts
Status: RESOLVED DUPLICATE of bug 50879
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-23 11:56 UTC by Lionel Elie Mamane
Modified: 2019-09-23 14:36 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
example odt file (9.07 KB, application/vnd.oasis.opendocument.text)
2019-09-23 12:01 UTC, Lionel Elie Mamane
Details
exported PDF file (11.57 KB, application/pdf)
2019-09-23 12:03 UTC, Lionel Elie Mamane
Details
PDF export options (63.38 KB, image/png)
2019-09-23 12:05 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2019-09-23 11:56:07 UTC
Description:
PDF export as PDF form of a document that contains form controls does not embed the fonts used in the form controls for user input.

Since these fonts will be needed when filling in the form, it seems to me that they should be embedded but not subsetted, since one doesn't know what the user will type in the PDF form.

Steps to Reproduce:
Create a document with form controls
Export as  PDF, check the "Create PDF form" checkbox, with "submit format" to PDF.

Actual Results:
Fonts used in the form input fields are not embedded.

Expected Results:
Fonts used in the form input fields should be embedded.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.5.2
Build ID: 1:6.1.5-3+deb10u4
CPU threads: 8; OS: Linux 4.9; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.utf8); Calc: group threaded
Comment 1 Lionel Elie Mamane 2019-09-23 12:01:37 UTC
Created attachment 154386 [details]
example odt file
Comment 2 Lionel Elie Mamane 2019-09-23 12:03:23 UTC
Created attachment 154387 [details]
exported PDF file

Note the output of pdffonts:
$ pdffonts fdo127717.pdf 
name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
BAAAAA+LiberationSerif               TrueType          WinAnsi          yes yes yes     11  0
Carlito                              TrueType          WinAnsi          no  no  no      13  0


"LiberationSerif", used in the document text is embedded and subsetted. But "Carlito", used for the text box (user input in the PDF form) is not embedded.
Comment 3 Lionel Elie Mamane 2019-09-23 12:05:16 UTC
Created attachment 154388 [details]
PDF export options
Comment 4 NISZ LibreOffice Team 2019-09-23 14:36:08 UTC

*** This bug has been marked as a duplicate of bug 50879 ***