Download it now!
Bug 127728 - FILEOPEN: WMF image in .doc (and other formats) is displayed black
Summary: FILEOPEN: WMF image in .doc (and other formats) is displayed black
Status: RESOLVED DUPLICATE of bug 68810
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, filter:doc, regression
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2019-09-24 02:45 UTC by Jinpo
Modified: 2019-12-02 18:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Doc1.doc (60.50 KB, application/msword)
2019-09-24 02:47 UTC, Jinpo
Details
Print dialog display (66.79 KB, image/png)
2019-09-24 02:48 UTC, Jinpo
Details
The included image (133.18 KB, image/x-wmf)
2019-09-24 11:20 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jinpo 2019-09-24 02:45:40 UTC
Description:
When printing the document using libreoffice, the image object is all black.

When using libreoffice to export the document to PDF, the image object is also completely black.

Steps to Reproduce:
1.Open Doc1.doc use LibreOffice.
2.File -> Print
3.The print dialog displays as PrintDialog.png

Actual Results:
Image object of the document cannot be printed normally

Expected Results:
Print the document normally


Reproducible: Always


User Profile Reset: No



Additional Info:
版本: 6.3.1.2 (x64)
Build ID: b79626edf0065ac373bd1df5c28bd630b4424273
CPU 线程: 4; 操作系统: Windows 10.0; UI 渲染: 默认; VCL: win; 
区域语言: zh-CN (zh_CN); UI 语言: zh-CN
Calc: threaded
Comment 1 Jinpo 2019-09-24 02:47:32 UTC
Created attachment 154396 [details]
Doc1.doc
Comment 2 Jinpo 2019-09-24 02:48:30 UTC
Created attachment 154397 [details]
Print dialog display
Comment 3 Xisco Faulí 2019-09-24 10:29:17 UTC
Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: a283627036c9b1c56e4b765866b8fb8a26ec87ab
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

this is not a PDF problem, the image is already black when importing into LibreOffice
Comment 4 Xisco Faulí 2019-09-24 10:32:39 UTC
Interestedly, the image is displayed in

Versión: 6.3.1.2 (x86)
Id. de compilación: b79626edf0065ac373bd1df5c28bd630b4424273
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 5 Xisco Faulí 2019-09-24 10:33:23 UTC
@Bartosz, @Regina, I thought you might be interested in this issue...
Comment 6 Regina Henschel 2019-09-24 11:20:20 UTC
Created attachment 154423 [details]
The included image

It has nothing to do with doc import. It is a problem with the included image itself. I have extracted that image. If you use this image in a new text document, you get the same error, that the print preview shows a black rectangle. Because other image processing apps and Writer itself show the image correctly, it is an error somewhere in producing the preview.
Comment 7 Timur 2019-12-02 18:01:42 UTC
LO 3.5 opened fine. In LO 3.6 image was visible but dark. LO 4.0 is wrong.
Still black in master LO 6.5+ in Windows.
Regression. I'll put from 3.6 where worsened.
And all that makes it a probable duplicate of bug 68810.

*** This bug has been marked as a duplicate of bug 68810 ***