Bug 127754 - Ability to apply multiple modifier-styles to the same content
Summary: Ability to apply multiple modifier-styles to the same content
Status: RESOLVED DUPLICATE of bug 115311
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Styles-Paragraph
  Show dependency treegraph
 
Reported: 2019-09-25 08:31 UTC by Eyal Rozenberg
Modified: 2019-09-30 07:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2019-09-25 08:31:09 UTC
Often, a style can (and should) be thought of as a modification over an underlying style. This is very obvious for character styles, e.g. :

* An "Emphasize" style makes the text bolder (or underlined).
* A "Quoted" character style may change the font, or italicize the text.
* An "Enlarged" style may increase the text size by 20% relatively.

Now, what if you want to emphasize part of a quotation?

Obviously, you want to apply "Quoted" to the whole quotation, and "Emphasize" to a part of it - but you don't want the "Quoted" features to go away! ... yet go away they do, right now. This forces you to have "Emphasized Quoted" or "Enlarged Quoted" styles, which is artificial and annoying.

Actually, this may also apply to paragraph styles. For example, suppose we want to lay out content in two boxes on a page, of different widths. In each of these boxes we might have "Heading N" styles, "Text Body" and so on - which might be different. We shouldn't have to duplicate all of these styles, but rather factor out some basic "Box 1 Default" and  "Box 2 Default", and allow the other styles be the _same_ modifications of that (unless we really do want wackier differences).


I realize this would be a fundamental change, and that it should be considered carefully, since it could potentially confuse novice users if it were to just replace the current style system. But it is important and useful enough to consider. It has the potential of simplifying and streamlining the work of many more advanced users.
Comment 1 Dieter 2019-09-28 04:47:05 UTC
Eyal why don't you smply work with character styles, if you want to emphasize part of a qutotation?

cc: Design Team for further input
Comment 2 Heiko Tietze 2019-09-30 07:36:51 UTC
I understand Emphasize and Quoted as character styles, which should become combined. The open document format allows to do that, it could be realized as multi-selection of character styles or like paragraph styles with a hierarchy. The topic is discussed in bug 115311.

*** This bug has been marked as a duplicate of bug 115311 ***