Bug Hunting Session
Bug 127766 - Saving PPT leads to crash on iOS
Summary: Saving PPT leads to crash on iOS
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: iOS (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other iOS
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-25 14:49 UTC by Nicolas Christener
Modified: 2019-10-07 08:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
An empty ppt file which can be used for testing (44.50 KB, application/vnd.ms-powerpoint)
2019-09-25 14:53 UTC, Nicolas Christener
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Christener 2019-09-25 14:49:52 UTC
Description:
Saving (an empty) ppt file in the iOS app crashes the app.

Steps to Reproduce:
1. Open a ppt file in the iOS app
2. Change something
3. Save the file

Actual Results:
The app crashes.

Expected Results:
The file should be saved.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Nicolas Christener 2019-09-25 14:53:03 UTC
Created attachment 154496 [details]
An empty ppt file which can be used for testing

This file was created by MS Office.
Comment 2 Xisco Faulí 2019-09-26 08:51:41 UTC
Moving to NEW as agreed in the ESC meeting
Comment 3 Tor Lillqvist 2019-10-03 14:37:22 UTC
Was caused by ODR violation, fix in https://gerrit.libreoffice.org/80143 .
Comment 4 Commit Notification 2019-10-03 15:36:44 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6ad127ead70cc0942c9876556dda7f525d7d01a0

tdf#127766: Avoid ODR violation for class/struct FieldEntry

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Nicolas Christener 2019-10-06 08:27:47 UTC
Fixed. Tested in 4.1.64.

The issue can be closed.

Thanks a lot to the Collabora team for fixing this!