Bug 127801 - SCROLLING: Optimal View Zoom Moves Left-Right, with no convenient means to recenter the view
Summary: SCROLLING: Optimal View Zoom Moves Left-Right, with no convenient means to re...
Status: RESOLVED DUPLICATE of bug 37817
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2019-09-26 18:24 UTC by Y
Modified: 2020-05-11 09:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison: Optimal Zoom vs Page Width Zoom (95.31 KB, image/png)
2020-02-20 02:57 UTC, Y
Details
Scrolling: Optimal Zoom vs Page Width Zoom (87.27 KB, image/png)
2020-02-20 02:58 UTC, Y
Details
Optimal view vs page width (229.11 KB, image/png)
2020-02-25 08:30 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Y 2019-09-26 18:24:23 UTC
Description:
Until a few updates ago, View > Zoom > Optimal View was a great way to maximize screen usage: it used the full width of the window to show the area between the left and right margin.  I could see the full content I was editing in the largest possible resolution and scroll up and down in the document.

In recent version, scrolling with the touchpad also scrolls left and right, showing the (unnecessary) white border on the one side at the detriment of the (useful) content on the other side.

Steps to Reproduce:
1. open a document
2. view -> zoom -> optimal view
3. scroll left and right on the touch pad

Actual Results:
the view zooms to the border areas of the document

Expected Results:
no left-right move.  should only scroll up down.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Oliver Brinzing 2019-09-28 09:50:34 UTC
i can not see a difference between LO 6.3 and older LO versions.

Have you tried with View > Zoom > "Page Width"?
Comment 2 Y 2019-09-28 14:41:22 UTC
View > Zoom > "Page Width" works as expected: only scrolling up/down.

However, comparing "Page Width" vs. "Optimal" the result is a loss of approximately 25% when working on page width of 21cm (typical Letter format) and margins of 2x2.5cm.

While I currently use "Page Width" as a workaround on my 3480x2160 desktop, the workaround is a problem on a 1440x900 laptop when trying to work on two writer documents/windows side by side, each occupying 1/2 of the horizontal resolution.

So even assuming this is not a regression, horizontal scrolling should be locked in "Optimal" zoom, like it seem to be in "Page Width" zoom.

Thanks so much for listening to the ramblings of a usability nerd.
Comment 3 Xisco Faulí 2019-09-30 11:22:28 UTC
You can't confirm your own bugs. Moving it back to UNCONFIRMED until someone
else confirms it.
Comment 4 Xisco Faulí 2019-10-04 13:49:57 UTC
Hello Y,
why is it considered a regression? In which version it worked as expected in your comment ?
Comment 5 Y 2019-10-04 14:00:28 UTC
It looks like a regression to me because it used to be better in a previous version.  For a couple of years now I have been using View > Zoom > Optimal View to maximize horizontal resolution of the document being processed in writer and I could simply scroll up and down by moving two fingers on the trackpad.

Suddenly, a few weeks or months ago, my same two fingers scrolling resulted in both vertical (desirable) scrolling and horizontal (undesirable) scrolling.  At first I kind of put up with it, but at some point it reached annoyance status and this is when I started to use View > Zoom > Page Width.  The functionality is the same, but I am loosing about 20%-25% resolution, which on a 1440x900 display becomes unusable; and on a 1920x1080 display is barely usable.  With View > Zoom > Optimal the resolution is usable in both, but when I scroll and do not pay extreme attention to not move my fingers left or right, I loose the optimal view.

I do not know in which version it worked.  It is one of those things that I put up with as annoyance until it became annoying enough to file a bug report.  So if you want, do not call it a regression and call it a feature request, but please, lock left-right scrolling in optimal view to make it optimal.

Thank you also for making me aware that I should not change the bug status from NEEDINFO to CONFIRMED.  I am moving it back to UNCONFIRMED, hoping that somebody will confirm that the behavior of scrolling left-right when in Optimal View is detrimental to the optimal of the view.
Comment 6 Dieter 2019-10-13 05:16:05 UTC
Y, I also can't see any difference between LO 6.3 and older versions. So let's remove REGRESSION until we have more informations.

Just for clarification: Do you expect to remove horizontal scrollbar in optimal zoom or only that left-right scrolling is locked?
Comment 7 Y 2019-10-18 13:45:58 UTC
(In reply to Dieter Praas from comment #6)
> Do you expect to remove horizontal scrollbar in
> optimal zoom or only that left-right scrolling is locked?

Thanks for your interest in my expectations, Dieter.

locking left-right scrolling is good enough as it prevents a loss of about 25% of screen value.

the horizontal scrollbar is unnecessary.  If it is easy to remove it as well, great.  if not, leaving it there is a very minor inefficiency as the resulting vertical gain of approximately half line of text is nearly unnoticeable and does not affect usability.
Comment 8 Dieter 2020-01-10 11:25:59 UTC
Y, if the bug still persists, could you please add a screenshot? Perhaps that makes the problem more clear.
Comment 9 Xisco Faulí 2020-02-17 15:21:28 UTC
(In reply to Dieter from comment #8)
> Y, if the bug still persists, could you please add a screenshot? Perhaps
> that makes the problem more clear.

Setting to NEEDINFO until the screenshot is provided
Comment 10 Y 2020-02-20 02:57:30 UTC
Created attachment 158017 [details]
Comparison: Optimal Zoom vs Page Width Zoom
Comment 11 Y 2020-02-20 02:58:18 UTC
Created attachment 158018 [details]
Scrolling: Optimal Zoom vs Page Width Zoom
Comment 12 Y 2020-02-20 03:05:26 UTC
Two screenshots attached.

The first screenshot compares "Optimal View" on the left vs "Page Width" on the right.

The second screenshot shows what happen when I move the fingers to scroll the document.  In Optimal View, if I do not pay attention to keep a perfectly straight movement on the trackpad, it scrolls left<->right.  That left<->right scrolling is unnecessary, unwanted, not useful, and is what makes the "Optimal View" not optimal.

"Page Width" keeps the scrolling optimal, but because horizontal space is lost to display the margins, the font is smaller and more difficult to read / work with.

Can you remove the horizontal scrolling (also the horizontal scrollbars) from Optimal View?

In the alternative, if somebody really find it useful to move left/right outside of the margins while in Optimal View, can you make it a toggle to lock/unlock horizontal scrolling so that the user does not have to attempt to lock the hand's movement on the touchpad, which is hard to achieve?

Thanks
Comment 13 Dieter 2020-02-20 07:46:35 UTC
Thanks for the screenshots and your explanations. I think, the actual situation is clear, but I can't asses, if this is the desired behaviour or not

cc: Design-Team for further input and decision
Comment 14 Heiko Tietze 2020-02-20 11:29:14 UTC
Version 5.2.7.2 has the same "Optimal View" as still and master.

It's a bit unclear to me what you suggest. Make "Optimal" work like "Page Width" and get rid of this option?
Comment 15 Y 2020-02-24 00:34:27 UTC
My *observation* is that the current "Optimal View":
- maximize horizontal space use (very desirable)
- allows for accidental horizontal scrolling (undesirable)

My *wish* is to have a mode that:
- maximize horizontal space use, like the current "Optimal View"
- locks horizontal scrolling to prevent accidental trackpad movements, like the current "Page Width" view

In terms of *suggestions*, I do not know if there is a use-case that makes the current "Optimal View" horizontal scrolling behaviour desirable.  Therefore, suggestion depends on whether horizontal scrolling has desirable function in Optimal View.

If horizontal scrolling is desirable in Optimal View, I suggest adding a switch to lock/unlock horizontal scrolling.

If horizontal scrolling is undesirable in Optimal View, I suggest locking horizontal scrolling in "Optimal View."

Others have better insight than me to make the decision.  For me, horizontal scrolling is generally rarely desirable.
Comment 16 Heiko Tietze 2020-02-24 07:24:55 UTC
It makes no sense to bind scrolling on/off to the zoom factor. Whether you get a horizontal scroll bar should depend solely on the content width. So again, if "Optimal" is not working for you why not using "Page Width"? Point is that we have plenty of zoom options that might have an unexpected label but work perfectly in all situations. I don't see room for improvement.
Comment 17 Y 2020-02-24 14:33:40 UTC
> if "Optimal" is not working for you why not using "Page Width"?

because using "Page Width" results in less pixels used to display the relevant document portion (that what is not blank, margin, or decoration) and this results in smaller text which is more difficult to read and edit.

> Whether you get a horizontal scroll bar should depend solely on the content width.

This I *almost* agree.  It should depend solely on the *relevant* content width.  When I select "Optimal View", I am telling the software that what is left and right of the margin is irrelevant.

> Point is that we have plenty of zoom options that might have an unexpected label > but work perfectly in all situations.  I don't see room for improvement.

The fact that you do not see room for improvement does not mean that there isn't any.  The claim that something works "perfectly in all situations" tells me that you are not interested looking for something that will disturb your picture-perfect world.  Whenever you are ready to look, I suggest that you recreate the use-case: comparing/editing two text documents, side-by-side, on a 1440x900 13" laptop display with a trackpad.  You tell me which zoom mode, "Optimal" or "Page Width" is preferable for editing; and you tell me which of the same zoom modes is preferable for scrolling with the trackpad; and you tell me if you are still of the opinion that zoom options work perfectly in all situations.  I am of the opinion that zoom options can be improved, and the improvement is to not scroll horizontally when the *relevant* content width fit the viewport.
Comment 18 V Stuart Foote 2020-02-24 15:24:40 UTC
This is really a facet/duplicate of zoom mode enhancment from bug 37817

And as there, the scroll bar remains a requirement--for other page (header, footer, track change) and off canvas elements (images and objects extending beyond page margins). 

But there is no convenient way to recenter the canvas frame when it is moved right/left via horizontal scroll bar or cursor movement.

Done as an UNO action, centering would need a keyboard shortcut, and a GUI action on the horizontal scrollbar (double click maybe?).

Could leave this open for a recenter UNO action with shortcut and GUI tweaks. Or close as needed for bug 37817
Comment 19 Y 2020-02-24 23:27:55 UTC
Thanks V Stuart Foote for drawing my attention to bug 37817.

Generally, I see the scroll bar requirement for off-canvas elements.  Your expert input confirm what I did not know but suspected at comment 15 when I stated that a suggestion depends on whether horizontal scrolling is desirable in Optimal View.

Where access to off-canvas elements is required, horizontal scrolling is obviously not just desirable, but also necessary.

Question is: can one of the zoom modes be dedicated to the case when the user deliberately decides not to access off-canvas elements by selecting said zoom mode?

I cannot volunteer technical suggestion on the specific implementation as I know practically nothing of LibreOffice internals.  Not sure that extra clicking or GUI action should be necessary.  I'd rather prefer the document to ignore the (unintended) horizontal movements on the touchpad.

I can volunteer that semantically, "Optimal View" makes me think of the most readable view (so: largest fonts / optimization of horizontal space to show only the text between the margins, knowing that I would see only parts of the off-canvas elements) with the most scrolling comfort (so: guided vertically).

A follow-up question is whether there needs to be an extra action to exit this kind of "guardrail scrolling mode" or the selection of any other zoom mode in the menu is sufficient?  Assuming that the guardrail mode is implemented, either in lieu of Optimal View or as an additional zoom mode.

As for the duplicate status, I will leave the decision to you, as you manage development and this analysis is input to your development work.  Do what makes your life easier, and let me know what I can contribute.  There is definitely overlap.  It is also kind of daunting to see that bug 37817 has been around for so many years.  Optimal Zoom as it stands today *almost* does the job.  What is it that makes it so difficult to lock horizontal scrolling?  I do not mind the horizontal bars remaining on screen (the optimization is horizontal).  I just do not want my clumsy touchpad movement to scroll the document out of the horizontal optimum position.

Thanks again.
Comment 20 Heiko Tietze 2020-02-25 08:30:02 UTC
Created attachment 158168 [details]
Optimal view vs page width

Window is 1440x900, Optimal View with 140% minimizes the document margins while Page Width and 120% is the maximum without a scrollbar. I don't see an advantage of either removing one of the two option or tweaking the number.

You can always read documents in full-screen, you can hide white-space (and we can talk about also hiding the horizontal margins in this mode though users request rather the opposite in bug 130023 and bug 126868), and you could temporarily switch to another page style without margins.

For now I would rather make this a duplicate of 37817.
Comment 21 Y 2020-02-25 15:17:33 UTC
Herr Tietze:

Please correct your logic:  TWO windows side by side on a 1440x900 display means 720x900 window.  Continue with your math from there.

Single window / full screen is a different use case.  The user here, and the user in bug 37817 need TWO windows side by side, and as Mr. Foote remarked here and in the bug 37817 thread, this is and remains a VALID ENHANCEMENT.

I understand your preference, Herr Tietze.  Answer this:  what is the point of a UX designer if the UX is already "perfect" and the UX designer sees "no room for improvement?"

I do not agree with your preference, because my concern is that your intention is to bury the TWO windows side-by side use case that is oh so disturbing to your picture-perfect UX view.  UX designers' role is to listen to the users, not to protect the status quo.  Your motivation clouds your judgment.
Comment 22 Heiko Tietze 2020-02-26 10:05:13 UTC
(In reply to Y from comment #21)
> 720x900 window

Optimal View = 96%, Page Width = 80% (81% adds the scrollbar).

To make my point clear: zooming in is a well-known function that always affects the scroll area. And I'm against spoiling generic features.

Of course I do understand your problem and suggest to consider a different solution. Either by changing the workflow (full-screen) or by tweaking some other option such as Hide Whitespace affecting also the left and right margins.

Removing needsUX for now.
Comment 23 Buovjaga 2020-05-11 09:10:31 UTC
Let's close as duplicate of bug 37817

*** This bug has been marked as a duplicate of bug 37817 ***