Bug 127802 - FONT EFFECTS: Not possible to hide/unhide when selection contains both hidden and unhidden text (GTK3)
Summary: FONT EFFECTS: Not possible to hide/unhide when selection contains both hidden...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0 target:7.0.2 target:6.4.7
Keywords: bibisectNotNeeded, regression
Depends on:
Blocks: GTK3 Font-Effects
  Show dependency treegraph
 
Reported: 2019-09-26 19:45 UTC by Dave_B
Modified: 2020-08-26 11:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot: Clicking "hidden" has no effect. Expected effect: Hide/unhide all marked text. (33.92 KB, image/png)
2019-09-26 19:45 UTC, Dave_B
Details
Example file (13.91 KB, application/vnd.oasis.opendocument.text)
2020-08-25 11:52 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave_B 2019-09-26 19:45:42 UTC
Created attachment 154566 [details]
Screenshot: Clicking "hidden" has no effect. Expected effect: Hide/unhide all marked text.

I work on client texts.

I often have to hide selected parts of a text, work on the visible text, and unhide the whole text again so I know what to work on and also for billing purposes. This is an integral part of my workflow.

I'd like to be able to click ctrl-f10, mark everything using ctrl-a and remove the hidden flag via Font Effects (or via key combo but that's not really the problem) as I can in MS Word.

LO Writer does not allow me to change the corresponding checkmark in Font Effects unless all the text under it is either hidden or unhidden. I haven't found a way of doing a search and replace using formatting as "hidden" is the only option in Font Effects that Search/Replace doesn't include.

So I have to go through each section individually and manually unhide it. Which seems to be an awful lot of unnecessary work.

At the moment I have to start up a Windows VM, start Word, and open the document just to be able to unhide all the hidden text sections. 

IIRC this was not a problem on previous versions of LO writer.

I am aware that I can select "Clear direct formatting" but that destroys all formatting, not just the hidden flag, so that's not really an option.

Unfortunately, I'm very limited as to what I can and can't do to a text as I process client files that are sent to me, and have to send them back with only the alterations that are actually required by the client. That includes applying styles, conditional formatting and similar.
Comment 1 Oliver Brinzing 2019-09-28 09:55:10 UTC
Can you please check if your issue refers to:

Bug 127550 - "Amend Help with Options for hidden text, Formatting Aids and Display Fields" including "See Also" issues ?
Comment 2 Dave_B 2019-10-06 15:52:13 UTC
They're different issues. Bug 127550 refers to displaying hidden text using the Ctrl-f10 toggle only, whereas this bug 127802 refers to the behaviour of setting or unsetting the hidden flag using the Format -> Character/Font Effects tab on a text with both hidden and unhidden components after activating "show hidden characters" via Ctrl-f10.
Comment 3 Dave_B 2019-10-06 17:23:17 UTC
I've checked for this on my Raspberry Pi (LO version 6.1.5.2) and Windows 10 32 bit VM (LO version 6.3.2.2):

Pi: Works as it should
W10: Works as it should

The LO version on Linux is now also 6.3.2.2. Bug still persists.
Comment 4 Dave_B 2019-10-07 17:12:55 UTC
I also tried this after renaming my ~/.config/libreoffice and thus effectively returning LO to new install conditions, bug still persists.
Comment 5 Dieter 2019-10-10 06:48:02 UTC
I also can't confirm it with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 460908269972fd1f89312a1e62897ed1503e9e98
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-30_09:18:03
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Dave, could you please paste informations from Help => About LibreOffice?
Comment 6 Dave_B 2019-10-13 19:34:06 UTC
To reiterate, it works properly on Windows 10 32 bit and on Raspbian (checked), but not on Linux:

Version: 6.3.2.2
Build ID: 6.3.2-2
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.utf8); UI-Language: en-US
Calc: threaded
Comment 7 Dave_B 2019-12-12 15:08:34 UTC
Still not working.

Version: 6.3.3.2.0+
Build ID: 6.3.3-2
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.utf8); UI-Language: en-US
Calc: threaded
Comment 8 Buovjaga 2020-04-27 18:39:30 UTC
(In reply to Dave_B from comment #7)
> Still not working.
> 
> Version: 6.3.3.2.0+
> Build ID: 6.3.3-2
> CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3; 
> Locale: en-GB (en_GB.utf8); UI-Language: en-US
> Calc: threaded

Which Linux distro are you using? As it works with Raspbian, you are probably seeing some distro-specific issue.

You could also try with a master build:
https://dev-builds.libreoffice.org/daily/master/current.html
https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 9 Dave_B 2020-08-25 11:34:51 UTC
I'm using it on Arch, but I've also tested it on Ubuntu (after adding the respective repo for the latest version) I tried Ubuntu some time ago and have since deleted the VM.

Version is now 7.0.0.3 and it's still not working.
Comment 10 Dave_B 2020-08-25 11:36:06 UTC
Version: 7.0.0.3
Build ID: 7.0.0-1
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.utf8); UI: en-US
Calc: threaded
Comment 11 Dave_B 2020-08-25 11:41:00 UTC
I really doubt it's a distro-specific issue, although there could be some upstream dependency problem. Older versions of LO worked as they should. Raspbian uses ancient versions of everything.
Comment 12 Buovjaga 2020-08-25 11:52:42 UTC
Created attachment 164669 [details]
Example file

This is only seen with GTK3, not with gen or kf5

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 02c3cca1fb5a0c2dbdf4ce55a5f07ebb64bcaed7
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 25 August 2020
Comment 13 Commit Notification 2020-08-25 14:52:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4b4f5eecc6ebb4a67a21ed60f07910f3c11f2db3

tdf#127802 support tristate for hidden/unhidden text

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Caolán McNamara 2020-08-25 15:18:29 UTC
fixed in master, backport to 7-0 and 6-4 in gerrit
Comment 15 Buovjaga 2020-08-25 17:25:07 UTC
Works!

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: e2fe4fde592564d35099ad1e2659ad682dfb77f5
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 25 August 2020
Comment 16 Commit Notification 2020-08-26 10:36:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/fdab135ddc845ddaf2014fd35b81e23a83e2c356

tdf#127802 support tristate for hidden/unhidden text

It will be available in 7.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2020-08-26 11:17:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/9adb750c0066cda6f534e8e9430de5b236f4b2bd

tdf#127802 support tristate for hidden/unhidden text

It will be available in 6.4.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.