Bug 127822 - CALC FILEOPEN, FILESAVE: Excel Import/Export changes cell contents for Boolean cells
Summary: CALC FILEOPEN, FILESAVE: Excel Import/Export changes cell contents for Boolea...
Status: RESOLVED DUPLICATE of bug 122098
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-27 11:51 UTC by Axel Howind
Modified: 2022-02-23 16:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
original file saved in excel (8.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-09-27 11:52 UTC, Axel Howind
Details
file saved in LibreOffice (5.36 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-09-27 11:53 UTC, Axel Howind
Details
screenshot (1.60 MB, image/png)
2019-09-27 11:54 UTC, Axel Howind
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Howind 2019-09-27 11:51:46 UTC
Description:
Boolean values are changed when opening and saving excel workbooks.

I have attached sample workbooks that I created using Excel. In the first cell I typed in "TRUE", in the cell below "=TRUE". Both display as "TRUE" in Excel (see screenshot). When opened in LibreOffice, both display as "1". When saving as "savedInLibreOffice" to xls format from wihtin libreoffice again, the cell contents are changed as can be seen on the screenshot.

This is an issue since we encountered this when programmatically processing excel documents and values from boolean cells could not be evaluated after making changes in LibreOffice even though the sheet containing the boolean values had not been altered (only the text of a single cell on another sheet had been changed).

description of screenshot:

top: document "savedInExcel" opened in Excel (left) vs LibreOffice (right)
bottom: document "savedInLibreOffice" opened in Excel (left) vs LibreOffice (right)

LibreOffice version: LibreOffice Version: 6.3.2.2 (same issue with 6.3.1.2)
Excel version: Microsoft Excel for Mac Version 16.29.1


Steps to Reproduce:
1. Open attached workbook "savedInExcel.xlsx" in Calc
2. Save again in xlsx format
3. Compare with original (preferrably in Excel if available)

Actual Results:
Cell A1 content changed from "TRUE" (no '=') to "=TRUE()" (added '=' and '()')
Cell A2 content changed from "=TRUE" to "=1"

Expected Results:
cells contents should not change


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: StartModule
[Information guessed from browser]
OS: Mac OS X (All)
OS is 64bit: no
Comment 1 Axel Howind 2019-09-27 11:52:41 UTC
Created attachment 154596 [details]
original file saved in excel
Comment 2 Axel Howind 2019-09-27 11:53:19 UTC
Created attachment 154597 [details]
file saved in LibreOffice
Comment 3 Axel Howind 2019-09-27 11:54:15 UTC
Created attachment 154598 [details]
screenshot
Comment 4 Oliver Brinzing 2019-09-28 12:48:46 UTC
> When opened in LibreOffice, both display as "1".

confirming

> Cell A1 content changed from "TRUE" (no '=') to "=TRUE()" (added '=' and '()')
> Cell A2 content changed from "=TRUE" to "=1"

both cells use default cell format, after changing cell format to "Boolean Value" both cells display "TRUE", but cell A1 is still =True(), and A2 is =1
Comment 5 QA Administrators 2022-02-05 03:42:06 UTC Comment hidden (obsolete, spam)
Comment 6 Justin L 2022-02-23 16:04:37 UTC

*** This bug has been marked as a duplicate of bug 122098 ***