Download it now!
Bug 127829 - Some Start Center layout reworking
Summary: Some Start Center layout reworking
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2019-09-27 19:27 UTC by Roman Kuznetsov
Modified: 2019-10-05 08:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
mockup (54.32 KB, image/jpeg)
2019-09-27 19:27 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2019-09-27 19:27:08 UTC
Description:
Some Start Center layout reworking.


now we have very strange situation with selecting of controls in Start Center (for me of course)
by default we have two selection: one for button "Open File" and second is drop-down list "Recent Files"
and if you'll move mouse point over buttons then you'll see select effect on buttons (see screenshot, button "Calc Spreadsheet")
It's very confuse me now
and we have two main groups of controls - buttons for actions (open, create docs by modules) and controls for filtering of content in Start Screeen (Recent Files and Templates)
but controls for filtering are between two button's groups
and two from these groups don't have labels

So I suggest to make some changing in Start Screen layout (see attach)

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Roman Kuznetsov 2019-09-27 19:27:59 UTC
Created attachment 154606 [details]
mockup
Comment 2 Heiko Tietze 2019-09-30 07:49:04 UTC
I don't get your concerns about the controls. Is it really the highlighting of Recent Files and modules when hovering over it? They have slightly different colors, and it's not "very confusing" to me.

And your proposal moves the section with Recent Files and Templates below the Create section - don't see this as a solution to the issue. Plus, Recent Files next to open is more common IMHO.

So I would refrain from changing this.
Comment 3 Thomas Lendo 2019-10-02 20:24:39 UTC
Hm, I also don't share your concerns about the Start center buttons.

The only change I support is your idea of headings 'Open', 'Show' (instead of the longer string 'Show on screen') and 'Create' because that would unify the UI arrangement. Only the bigger height of the screen could be a problem as it's now hard on the limit especially on smaller screens like laptops and tablets.
Comment 4 Cor Nouws 2019-10-03 12:06:36 UTC
(In reply to Roman Kuznetsov from comment #1)
> Created attachment 154606 [details]
> mockup
Thanks Roman!
IMO the word "Show" does make it better.
But I don't like the position at the bottom.
Comment 5 Heiko Tietze 2019-10-05 08:12:21 UTC
Wouldn't it look weird when the caption "Open" is followed by "Open File"? And actually "Show" is rather a filter and provides also access to the template manager. Finally, the actually shown "Create" is known as "New" in the menu.

Putting all together, there is no agreement to replace the buttons while some more captions are accepted. However, it doesn't solve any issue, adds other inconsistencies and raise the height trouble. So WF.