Bug 127855 - FORMATTING: A heading doesn't get Chapter Numbering (other headings do)
Summary: FORMATTING: A heading doesn't get Chapter Numbering (other headings do)
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.1.1 rc
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chapter-Numbering
  Show dependency treegraph
 
Reported: 2019-09-29 08:36 UTC by Duong Do Minh Chau
Modified: 2020-06-05 05:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The document containing the heading with problem (10.60 KB, application/vnd.oasis.opendocument.text)
2019-09-29 08:39 UTC, Duong Do Minh Chau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Duong Do Minh Chau 2019-09-29 08:36:08 UTC
Description:
When I add a new heading for my document, it doesn't get the prefix from Chapter Numbering. I add this by creating a new line, enter some text, then change the paragraph style to Heading 1. Even if I click Reset, in the Chapter Numbering dialog, it is still being ignored. The strangest part is when I try adding another heading using the same steps above, the new one doesn't have the problem. Don't know if it's because I've clicked Reset or just random.

Steps to Reproduce:
Can't reproduce

Actual Results:
The heading style is applied but the Chapter Numbering is not.

Expected Results:
Both the heading style and the Chapter Numbering is applied.


Reproducible: Couldn't Reproduce


User Profile Reset: No



Additional Info:
Comment 1 Duong Do Minh Chau 2019-09-29 08:39:03 UTC
Created attachment 154633 [details]
The document containing the heading with problem
Comment 2 Duong Do Minh Chau 2019-09-29 08:39:29 UTC
I've just noticed that when I change the style to Title and change back to Heading 1, the problem disappear.
Comment 3 Dieter 2019-10-02 11:46:54 UTC
(In reply to Duong Do Minh Chau from comment #2)
> I've just noticed that when I change the style to Title and change back to
> Heading 1, the problem disappear.

I confirm the behaviour with

Version: 6.3.2.2 (x64)
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

=> set status to NEW
Comment 4 Timur 2019-10-08 14:20:00 UTC
If behavior is confirmed, that's still not enough to confirm the bug. 
We don't have steps here not we see the cause. 

Looking into file contents, "the problem" heading has text:is-list-header="true"

Per standard, the text:is-list-header attribute specifies the appearance of a specific heading without numbering. 
The defined values for the text:is-list-header attribute are:
● false:  heading  will  be numbered.
● true:  heading will  be  not  numbered, even if the header  has a list -style ..

So, that's at it should be, NotABug.

That being said, I wonder how that got into document. And how do we put it there if we need, where's that in LO.
Comment 5 David JAMES 2020-06-04 20:25:19 UTC Comment hidden (spam)