Bug 127894 - Continuous crash on macOS 10.12.6
Summary: Continuous crash on macOS 10.12.6
Status: RESOLVED DUPLICATE of bug 127619
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-01 00:32 UTC by tiago.montes
Modified: 2019-10-01 05:39 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tiago.montes 2019-10-01 00:32:35 UTC
Description:
System
------
MacBook Pro 2015 with retina display running macOS Sierra 10.12.6


Summary
-------
Launching LibreOffice causes it to "crash" displaying a dialog with the message "Due to an unexpected error, LibreOffice crashed. All files (...)" and a single [OK] button.
Clicking the button and recovering the open files (if any) relaunches leading to a subsequent "crash".

Applies to both "latest" available versions as of today: 6.3.2.2 and 6.2.7.1.


Details
-------
- LibreOffice self-crashes and no interaction is needed.
- I recorded my screen and observed that from the main window being displayed until the "crash" it consistently took a little over 35 seconds. Interestingly the "splash screen" is shown/hidden-away in a split-second (mush less than half a second).
- Things I tried:
  - Deleting the profile at ~/Library/Application Support/LibreOffice.
  - Creating a new user and using that account.
  - Running LibreOffice with a user with administrative privileges.
  - (Re)Starting in safe mode.
  - Rebooting the system.
  - Confirmed "use OpenCL" was disabled in the preferences.
- It consistently fails the same way regardless of any "cleanup" attempts I did.
- I checked all user and system level logs for any hints and found nothing.


With no knowledge of any kind of diagnostic procedure, I explored older versions:
- 6.0.0.1 seems to work ok.
- 6.1.0.1 seems to fail in the same way.
- 6.0.7.3 seems to work ok.

I reviewed the release notes for 6.1 here (https://wiki.documentfoundation.org/ReleaseNotes/6.1) and found a link to this article (https://www.collaboraoffice.com/community-news/recent-mac-specific-fixes-in-libreoffice/) but I have no way of telling how such changes could result in this very odd behaviour: auto-crashing consistently 35 seconds after displaying the main window... :(


Lastly
------
This is a **very** odd behaviour and I can't recall any recent changes I might have applied to the system -- and I am very conservative in such procedures as you can imagine by the >2 years old OS version -- but there might be something.

Any assistance you can provide in diagnosing this will be very much appreciated: count on my cooperation.

PS: Thanks a lot for LO! It is an amazing endeavor! :)

Steps to Reproduce:
1. Launch LibreOffice.
2. Wait for the main window to be displayed.
3. Wait 35 seconds.

Actual Results:
The main window disappears and a new smaller dialog window is displayed with the message "Due to an unexpected error, LibreOffice crashed. All files (...)" and a single [Ok] button.

Expected Results:
The main window should not disappear, allowing me to continue any task I was on to. :)


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Comment 1 tiago.montes 2019-10-01 01:03:00 UTC
After having logged this bug I went checking for its presence by searching for it. That's when I found (https://bugs.documentfoundation.org/show_bug.cgi?id=127619) which looks very much the same -- for some reason I failed to find it before.

Following that thread, I disabled checking for updates and now both "actual" versions no longer crash after the 35 seconds: that seems to be the culprit in my case.

Please let me know:
1. If I should close this bug and follow up on the other one.
2. If there is any detail/diagnostic I can provide to help fixing this.

Again, thanks a lot.
Comment 2 Alex Thurgood 2019-10-01 05:39:56 UTC

*** This bug has been marked as a duplicate of bug 127619 ***