Download it now!
Bug 127903 - CUSTOMIZE DIALOG: why is KEY_EQUAL not available for assignment to keyboard shortcuts
Summary: CUSTOMIZE DIALOG: why is KEY_EQUAL not available for assignment to keyboard s...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.4.0
Keywords: needsUXEval
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2019-10-01 11:27 UTC by ghfjdksl
Modified: 2019-10-16 20:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ghfjdksl 2019-10-01 11:27:11 UTC
Description:
Hi, I would like to request an extra set of shortcut combination with = key. For example: ctrl+=, alt+=.


Steps to Reproduce:
Open the shortcut list and there's no such combination assignable.

Actual Results:
N/A

Expected Results:
N/A


Reproducible: Always


User Profile Reset: No



Additional Info:
N/A
Comment 1 V Stuart Foote 2019-10-07 20:34:22 UTC
Confirmed, not sure why the KEY_EQUAL is excluded from use as assignment to a keyboard shortcut.

KEY_SUBTRACT, KEY_ADD, KEY_MULTIPLY, and KEY_DIVIDE are all available for use in a shortcut (with modifiers); so not clear why KEY_EQUAL would not be likewise availalbe. Is it assigned a 'reserved' status? If so, I could not find it...
Comment 2 Heiko Tietze 2019-10-08 09:33:15 UTC
https://gerrit.libreoffice.org/#/c/80436/

Tried to show "Ctrl+Equal" in the dialog instead of "Ctrl+=" but failed. And since l10n of these strings is hard-coded plus the keyboard has no "equal" label, it might be better to leave this alone.
Comment 3 Commit Notification 2019-10-08 14:40:46 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8519c6d98250a5f2b4c78e330fc79907c596a447

Resolves tdf#127903 - Allow customization with equal key

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Dieter 2019-10-16 20:39:59 UTC
Verified with

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 758516295e5f69393bd78bb4af6e7214d48ece0b
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: GL; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Heiko, thanks for fixing it.